Plesk

Let’s encrypt fails if domain is configured with captcha: Your domain in Plesk is hosted on the IP address(es): 203.0.113.2 , but the DNS challenge used another IP address: 203.0.113.3.

Symptoms

Cause

The token file is not accessible due to Cloudflare's cache.

Resolution

Note: In order to prevent such issues, exclude the token file path http://example.com/.well-known/acme-challenge/* according to the instruction from Cloudflare: How do I exclude a specific URL from Cloudflare's caching?

  1. Clear the Cloudflare's cache using steps from Cloudflare's article: How do I purge my cache?
  2. (In case captcha is enabled) Disable captcha for the domain.
  3. Issue/renew Let's encrypt certificate: Log in to Plesk > Domains > example.com > SSL/TLS Certificates > Install/Reissue Certificate.
  4. (In case captcha was enabled) Enable captcha for the domain back.
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