Plesk

Let’s Encrypt certificate installation fails for a domain in Plesk for Windows Server: The authorization token is not available

Symptoms

Cause

When the Require SSL/TLS or HSTS option is enabled for a domain in its IIS Settings, connections to URLs starting with HTTP instead of HTTPS are forbidden by the web server, however the Let's Encrypt servers can only use the HTTP-01 challenge while establishing a connection via port 80 (HTTP protocol) initially, which can be confirmed on the following page of the Let's Encrypt documentation:

HTTP-01 challenge | Challenge Types - Let's Encrypt

Due to this, using the Require SSL/TLS option in IIS for domains that use Let's Encrypt SSL certificates is not recommended, because the type of requests the Let's Encrypt servers make to your Plesk server is set entirely on the end of Let's Encrypt.

Resolution

  1. Log in to Plesk.

  2. Go to Domains > example.com > Hosting & DNS > IIS Settings > Directory Security Settings.

  3. Disable Require SSL/TLS option and save the changes.

  4. Reissue the certificate at Domains > example.com > SSL/TLS certificates.

  5. Enable Require SSL/TLS option at Domains > example.com > IIS Settings > Directory Security Settings if required.

Additional information

HTTP-01 challenge | Challenge Types - Let's Encrypt

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