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Knowledge Base

All websites are shown as “Quarantined” in WP Toolkit in Plesk even though they were successfully verified by antivirus

 
anti virusantivirusapplications extensionscachedebug

Symptoms

  • All websites are shown as "Quarantined" in Plesk WP Toolkit

  • When clicking on a website's name in WP Toolkit, the following message is displayed:

    WP Toolkit was not able to properly access website files. This is most likely caused by a malware infection.
    It is strongly recommended to check this website for viruses and malware. If you have identified and fixed the underlying issue, click Refresh.

  • Antivirus checks show no virus/malware found when scanning the websites.

  • External domains like ext.plesk.com or google.com cannot be resolved from the server:

    # dig +short google.com
    <no output>

  • The following error messages can be found in /var/log/plesk/panel.log with enabled debug mode:

    ERR [panel] Could not resolve host: ext.plesk.com
    ERR [extension/wp-toolkit] Unable to retrieve data by "https://api.wordpress.org/plugins/info/1.1/?action=query_plugins&request[page]=1&request[per_page]=40&request[browse]=popular&request[fields][description]=0&request[fields][short_description]=1"
    ERR [extension/wp-toolkit] Unable to retrieve data by "https://api.wordpress.org/core/version-check/1.7/"
    ERR [extension/wp-toolkit] Unable to retrieve data by "https://api.wordpress.org/core/version-check/1.7/"
    ERR [extension/xovi] Sorry, currently not able to connect to API.

    and:

    ERR [extension/wp-toolkit] Failed to reset cache for the instance #17, reason: WP Toolkit was not able to finish running an operation on this site in 60 seconds, so the operation was terminated. This could mean that your WordPress installation might be infected with malware. Check the wp-config.php file of the installation
    for potential malware code or run an anti-virus scan.
    If you cannot find any traces of malware, try running the operation again later.

Cause

A misconfiguration of DNS resolvers on the server.

Resolution

  1. Connect to the server using SSH

  2. Open the file /etc/resolv.conf and make sure that the nameservers specified in this file are operational.
    As a workaround, add Google's public resolver above all existing nameserver records in the file:

    nameserver 8.8.8.8

  3. Make sure that ext.plesk.com can be resolved from the server:

    # ping ext.plesk.com
    PING 1648825949.rsc.cdn77.org (81.27.240.179) 56(84) bytes of data.
    64 bytes from 81.27.240.179.rascom.as20764.net (81.27.240.179): icmp_seq=1 ttl=56 time=43.8 ms
    64 bytes from 81.27.240.179.rascom.as20764.net (81.27.240.179): icmp_seq=2 ttl=56 time=43.6 ms
    ...

  4. Log in to Plesk.

  5. Go to Extensions > My Extensions > WP Toolkit > Open and press the Refresh button (which is highlighted on the screenshot below):

    wordpress.png

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