Symptoms
A website has been migrated to Plesk from a legacy Plesk version.
When opening this website in a web-browser, it loads the real content over HTTP, but different over HTTPS. For HTTPS, it also can be a Plesk default page or Apache test page.
Opening other pages of the website over HTTPS result in "404 Not Found" or "403 Forbidden".
Cause
The domain is running in "Separate SSL/TLS and non-SSL/TLS content" compatibility mode.
Domains in Plesk 11 and earlier releases had their content stored in separate directories for HTTP and HTTPS:
-
- for HTTP content
/var/www/vhosts/example.com/httpdocs -
- for HTTPS content
/var/www/vhosts/example.com/httpsdocs
Resolution
Connect to the Plesk server via SSH.
Disable the compatibility mode in the Plesk database:
# plesk db "UPDATE hosting set same_ssl='true' WHERE same_ssl='false';"
Repair web-server configuration:
# plesk repair web -y