Symptoms
A Customer or Reseller logged into Plesk cannot view the Web Application Firewall button under Websites & Domains > example.com > Security
The Web Application Firewall button is visible for all domains while logged in as the Plesk Administrator.
The permission Hosting Settings management is turned off in one of the following locations:
- Plesk > Service Plans > SUBSCRIPTION_SERVICE_PLAN_NAME > Permissions
- Plesk > Resellers > RESELLER_NAME > View More Statistics > Permissions
Cause
The logged in user does not have Hosting Settings management permission enabled which controls the ability to see and manage Web Application Firewall settings.
Resolution
Log into Plesk as the Plesk Administrator
Turn on the Hosting Settings management permission accordingly:
For customer under Plesk > Service Plans > SUBSCRIPTION_SERVICE_PLAN_NAME > Permissions
For Reseller under Plesk > Resellers > RESELLER_NAME > View More Statistics > Permissions
Press the Update & Sync button (if it is visible) to save the changes.