Plesk

Unable to create a backup or restore Web Presence Builder snapshot in Plesk for Windows: Invalid Snapshot

Symptoms

Cause

The issue is caused by product bugs #PPPM-3483 and #PPPM-4869.

Resolution

Apply one of the solution below depending of the using Plesk version:

Warning: before applying the solution below, verify that website on which snapshot is tried to be restored is available via HTTP.

For Plesk Obsidian

  1. Log into the server via RDP.
  2. Press here to download the archive that contains a fix.

  3. Unpack the downloaded archive.

  4. Create a backup of the original file Target.php located in %plesk_dir%sbincludeSBExtensionPP directory.

  5. Copy the Target.php file from the step №3 to %plesk_dir%sbincludeSBExtensionPP folder.

  6. Create a backup or restore a snapshot again.

For Plesk Onyx

  1. Log into the server via RDP.
  2. Press here to download the archive that contains a fix.
  3. Unpack the downloaded archive.
  4. Create a backup of the original file Target.php located in %plesk_dir%sbincludeSBExtensionPP directory.

  5. Copy the Target.php file from the step №3 to %plesk_dir%sbincludeSBExtensionPP folder.

  6. Create a backup or restore a snapshot again.

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