Plesk

Unable to access Acronis Backup extension in Plesk: An error has occurred. Please try again later or contact support

Symptoms

Cause

The issue happens because a token used for communication with Acronis cloud was marked as 'expired' and then revoked on the cloud side.
This happened because there were no calls from the extension UI to the cloud for a week.

Resolution

Register the server once again with the following steps:

  1. Log in to Backup Console directly via cloud.acronis.com

  2. Delete the affected Plesk Server from the console (backups will not be deleted):

  3. Connect to the server via SSH

  4. Execute the following command and type the Acronis username and password when requested:

    # printf "ACRONIS LOGINnUser: "; read USER; printf "Password: n"; read -s PASS; /usr/lib/Acronis/RegisterAgentTool/RegisterAgent -o register -t cloud -a https://cloud.acronis.com -u $USER -p $PASS