Plesk

The Plesk Email Security dashboard keeps loading, or statistics are not updated

Symptoms

Cause

The Plesk Email Security bug EXTCERT-3176

Resolution

Workaround:

  1. Log in to Plesk.
    2. Navigate to Tools & Settings > Plesk Email Security > Server Settings tab.
    3. Go to the Advanced settings and decrease the Days number in the Auto-cleanup section to 7:
    ​​
    4. Scroll down and press the Save button.
    5. Navigate to Tools & Settings > Scheduled Tasks (Cron jobs) and click Run Now near the /usr/local/psa/admin/bin/php -dauto_prepend_file=sdk.php '/usr/local/psa/admin/plib/modules/email-security/scripts/update-stats.php' task:

Workaround 2:

Warning: this workaround is based on removing the tables msgs and msgrcpt from PES database. All Plesk Email Security statistics will be lost.

  1. Log in to Plesk.

  2. Navigate to Tools & Settings > Database Servers.

  3. Press on the button which is highlighted on the screenshot below:

  4. Click emailsecurity database to select it:

  5. Click on the SQL button to open the menu below:

  6. Add the following SQL queries to remove the content of the tables "msgs" and "msgrcpt" and click Go:

    TRUNCATE TABLE msgs;
    TRUNCATE TABLE msgrcpt;

  7. Run the scheduled task /usr/local/psa/admin/bin/php -dauto_prepend_file=sdk.php '/usr/local/psa/admin/plib/modules/email-security/scripts/update-stats.php via Tools & Settings > Scheduled Tasks (Cron jobs) > Run Now and check if the issue persists after the task was executed:

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