Symptoms
Plesk is unresponsive and may say the license is expired
Plesk shows the following error
ERR [1] Token validation failed: Can not connect to 'ka.plesk.com' (6:6). Please check connection to 'ka.plesk.com' or contact Plesk support: <a href='https://www.plesk.com/support/' target='_blank'>https://www.plesk.com/support/</a>.; ; KV network error (ka.plesk.com: cURL cannot communicate with license server https://ka.plesk.com/jsonrest/pkp/20/verify-key (): Couldn't resolve host name(6)
Retrieving the license on the command line fails with one of these messages
ERR [panel] KeyUpdate Result code: 2 Unspecified error
ERR [panel] KeyUpdate Result desc: License key is not prolongated yetERR (3): KeyUpdate Result code: 2 Network failure
ERR (3): KeyUpdate Result desc: Couldn't resolve host nameka.plesk.comcan't be resolved by some of the serves' DNS resolvers:# dig ka.plesk.com @203.0.112.2
...
;; connection timed out; no servers could be reached
Cause
DNS server misconfiguration.
Resolution
Resolve the DNS server issue with the hosting provider, or change the system's DNS resolvers
Connect to the server via SSH and reinstall license key manually
# plesk bin license --install A00000-A00000-A00000-A00000-A00000