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Knowledge Base

Plesk installation/update/upgrade/repair fails: Couldn’t resolve host autoinstall.plesk.com/autoinstall-win.plesk.com

 
dnsfirewallgooglehostinginstallation upgrade

Symptoms

Plesk installation/update/upgrade/repair fails with one of the following errors:

File downloading products.inf3: Error: Couldn't resolve host 'autoinstall.plesk.com', retry...
Error: Couldn't resolve host 'autoinstall.plesk.com', retry...


Syntax error in file /root/parallels/PHP73_17/php73-ubt20.04-x86_64.inf3: Error reading end tag.


Error: Failed to read product information from the file : Can't process products.inf3: Failed to download the file http://autoinstall.plesk.com/products.inf3:
Could not resolve host: autoinstall.plesk.com

Cause

The address autoinstall.plesk.com (on Plesk for Linux) or autoinstall-win.plesk.com (on Plesk for Windows servers) is not resolvable from a Plesk server due to network issues.

Resolution

  • Since the issue may be a temporary one, retry to update/upgrade Plesk later after some time.

  • If the issue still persists, perform the checks below and contact your hosting/ISP provider with the collected information for further troubleshooting of the network-related issue:

For Plesk for Linux

  1. Connect to a Plesk server via SSH.

  2. Check if autoinstall.plesk.com is accessible from the server using the ping and nslookup utility:

    # ping autoinstall.plesk.com

    # nslookup autoinstall.plesk.com

  3. Verify that a firewall is not blocking the connection.

  4. Make sure nameservers in the /etc/resolv.conf file are valid. In case of any doubts, use Google Public DNS IP addresses as shown below:

    # cat /etc/resolv.conf
    nameserver 8.8.8.8
    nameserver 8.8.4.4

  5. Check that there is no search record in the /etc/resolv.conf file. If the search record is present, it prevents the DHCP client from updating the file /etc/resolv.conf (if it is updated automatically). Either comment out the search directive or add the link to the host autoinstall.plesk.com as shown below:

    # cat /etc/resolv.conf
    ; generated by /sbin/dhclient-script
    search example.com autoinstall.plesk.com
    nameserver 192.0.2.2

For Plesk for Windows

  1. Connect to the Plesk server via RDP.

  2. Start a command prompt and check if autoinstall-win.plesk.com is accessible from the server using the ping and nslookup utilities:

    C:> ping autoinstall-win.plesk.com

    C:> nslookup autoinstall-win.plesk.com

  3. Verify that a firewall is not blocking the connection to autoinstall-win.plesk.com.

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