Skip to content
  • Solutions
    By Role
    • For Developers
    • For Content Managers
    • For Agencies
    • For IT Admins
    • For Web Hosters
    • For Developers
    • For Content Managers
    • For Agencies
    • For IT Admins
    • For Web Hosters
    By Infrastructure
    • Overview
    • AWS
    • Microsoft Azure
    • Alibaba Cloud
    • Google Cloud Platform
    • Vultr
    • Overview
    • AWS
    • Microsoft Azure
    • Alibaba Cloud
    • Google Cloud Platform
    • Vultr
    • Digital Ocean
    • Linode
    • Upcloud
    • Oracle
    • OVH
    • Digital Ocean
    • Linode
    • Upcloud
    • Oracle
    • OVH
  • Product
    • Plesk Features
    • Plesk Editions
    • What’s new
    • Pricing
    • Roadmap
    • Lifecycle Policy
    • Extensions Catalogue
  • Pricing
  • Extensions
    Featured Extensions
    • SocialBee
    • WP Toolkit
    • Sitejet Builder for Plesk
    • SEO Toolkit
    • Joomla! Toolkit
    • Premium Email
    • Email Security
    • SocialBee
    • WP Toolkit
    • Sitejet Builder for Plesk
    • SEO Toolkit
    • Joomla! Toolkit
    • Premium Email
    • Email Security
    Bundles and packs:
    • Business and Collaboration Edition
    • WP pack
    • Hosting pack
    • Power pack
    • Language pack
    • Business and Collaboration Edition
    • WP pack
    • Hosting pack
    • Power pack
    • Language pack

    See all Extensions

  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
  • Pricing
  • Solutions
    • By Role
      • For Developers
      • For Content Managers
      • For Agencies
      • For IT Admins
      • For Web Hosters
    • By Infrastructure
      • Overview
      • Plesk on Amazon Web Services (AWS & Lightsail)
      • Microsoft Azure
      • Alibaba Cloud
      • Google Cloud Platform
      • Vultr
      • DigitalOcean
      • Linode
      • UpCloud
      • Oracle
      • OVH
  • Products
  • Pricing
  • Extensions
    • Featured Extensions
      • SocialBee
      • WP Toolkit
      • Sitejet Builder for Plesk
      • SEO Toolkit
      • Joomla! Toolkit
      • Premium Email
      • Email Security
    • Bundles and packs:
      • Business and Collaboration Edition
      • WP pack
      • Hosting pack
      • Power pack
      • Language pack
      • See all Extensions
  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate Program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
  • Pricing
  • Solutions
    • By Role
      • For Developers
      • For Content Managers
      • For Agencies
      • For IT Admins
      • For Web Hosters
    • By Infrastructure
      • Overview
      • Plesk on Amazon Web Services (AWS & Lightsail)
      • Microsoft Azure
      • Alibaba Cloud
      • Google Cloud Platform
      • Vultr
      • DigitalOcean
      • Linode
      • UpCloud
      • Oracle
      • OVH
  • Products
  • Pricing
  • Extensions
    • Featured Extensions
      • SocialBee
      • WP Toolkit
      • Sitejet Builder for Plesk
      • SEO Toolkit
      • Joomla! Toolkit
      • Premium Email
      • Email Security
    • Bundles and packs:
      • Business and Collaboration Edition
      • WP pack
      • Hosting pack
      • Power pack
      • Language pack
      • See all Extensions
  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate Program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
Plesk 360 login
Free Trial

Knowledge Base

Migration to Plesk can not be started: Failed to connect to target Plesk server by Plesk API Plesk error 1006 Access to API is disabled

 
backup restore migrationdatabasedebuggohttps

Symptoms

  • The following error is shown when starting the migration in Plesk, where 203.0.113.2 is the target server IP Address:

    Failed to connect to target Plesk server by Plesk API: Plesk error [1006]: Access to API is disabled for 203.0.113.2

  • It is possible to connect via telnet to the target server on 8443 port locally and remotely, for example:

    # telnet 203.0.113.2 8443
    Trying 203.0.113.2...
    Connected to 203.0.113.2.
    Escape character is '^]'.

  • The following records can be found in the migration debug log file:

    • Logfile location on Windows: %plesk_dir%varmodulespanel-migratorsessions/<date_of_session>/debug.log

    • Logfile location on Linux: /usr/local/psa/var/modules/panel-migrator/sessions/<date_of_session>/debug.log

  • D|MT|core.utils.common.http_xml_client|||API request to https://203.0.113.2:8443/enterprise/control/agent.php
    D|MT|core.utils.common.http_xml_client|||Request XML:
    D|MT|core.utils.common.http_xml_client|||<?xml version="1.0" encoding="utf-8"?>
    D|MT|core.utils.common.http_xml_client|||<packet version="1.5.2.1">
    D|MT|core.utils.common.http_xml_client||| <server>
    D|MT|core.utils.common.http_xml_client||| <get>
    D|MT|core.utils.common.http_xml_client||| <stat/>
    D|MT|core.utils.common.http_xml_client||| </get>
    D|MT|core.utils.common.http_xml_client||| </server>
    D|MT|core.utils.common.http_xml_client|||</packet>
    D|MT|core.utils.common.http_xml_client|||
    D|MT|core.utils.common.http_xml_client|||Response:
    D|MT|core.utils.common.http_xml_client|||<packet version="1.5.2.1">
    D|MT|core.utils.common.http_xml_client||| <system>
    D|MT|core.utils.common.http_xml_client||| <status>error</status>
    D|MT|core.utils.common.http_xml_client||| <errcode>1006</errcode>
    D|MT|core.utils.common.http_xml_client||| <errtext>Access to API is disabled for 203.0.113.2</errtext>
    D|MT|core.utils.common.http_xml_client||| </system> </packet>

  • Plesk IP access policy is configured on the target server: in the menu Tools & Settings > IP Access Restriction Management > Settings, the option Access to Plesk with administrator's privileges is set to Denied from the networks that are not listed.

Cause

Plesk API is unable to access the target server locally because the server's own IP address is not present in the list of allowed IP addresses.

Resolution

  1. Log in to Plesk on the target server.

  2. Go to Tools & Settings > IP Access Restriction Management.

  3. Allow the target server IP address: click Add Network and enter the IP address.

Command-line solution

  1. Connect to the target server via SSH.

  2. Create a dump of the Plesk database.

  3. Access the Plesk database:

    # plesk db

  4. Add the target server's IP address to the list of allowed IP addresses:

    insert into cp_access (type, netaddr, netmask) values ('deny' , '203.0.113.2', '255.255.255.255');

Tweet
Share
Share
Email
0 Shares
Read the full article
Related Posts

How to Host a Go App on Plesk

Read More »

Plesk with Centralized Database and Network File System

Read More »

Debugging in WordPress Explained

Read More »
Knowledge Base

 An operation fails in Plesk: SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry ‘X’ for key ‘PRIMARY’

Read More »

How to provide Plesk Support with server access?

Read More »

How to customize Plesk URL

Read More »

Incoming mail to a Plesk server gets rejected: Client host blocked using zen.dnsbl

Read More »

Hosting Wiki

  • Django
  • Server Redundancy
  • Linux Containers
  • Google Cloud CDN
  • AMP
  • Bare Metal Server
  • Backup
  • Oracle VM Server
  • Server Virtualization Software
  • Windows Server
  • Linux
  • JavaScript
  • MongoDB
  • Plesk
  • SQL database
  • NoSQL Database
  • Web Server
  • DNS Server
  • IPv6
  • IPv4
  • SIP
  • SSH
  • UDP/IP
  • Network Bandwidth
  • TCP/IP
  • HTTP
X-twitter Linkedin Youtube Reddit Github
  • Product
  • Login
  • Pricing
  • Editions
  • For Partners
  • Partner Program
  • Contributor Program
  • Affiliate Program
  • Plesk University
  • Company
  • Blog
  • Careers
  • Events
  • About Plesk
  • Our Brand
  • Resources
  • User and Admin guides
  • Help Center
  • Migrate to Plesk
  • Contact Us
  • Hosting Wiki
  • Forum
  • Legal
  • Legal
  • Privacy Policy
  • Imprint

© 2025 WebPros International GmbH

Part of the WebPros®  Family