Symptoms
- Failed backups cannot be removed from a list in Tools & Settings > Backup Manager
- The backup checkbox is greyed out and can not be selected
Cause
Failed backup task is stuck in the tasks.db database
Resolution
Linux
Connect to the server via SSH
Access the backup tasks database:
# sqlite3 /usr/local/psa/PMM/tasks/tasks.db
Find the failed task by timestamp and remove it.
For example, the failed backup session was created 2020-09-01:
SELECT * FROM tasks WHERE dump LIKE '%2020-09-01%;
Examine the query output, and remove the task if the session timestamp matches the stuck one:
DELETE FROM tasks WHERE id=2;
Windows
Connect to the server via RDP
- Download the sqlite3 client from this link and extract it to any convenient location (e.g.
C:sqlite) Open the command prompt as Administrator and access the backup tasks database
C:> "C:sqlitesqlite3.exe" "%plesk_dir%PMMtaskstasks.db"
Find the failed task by timestamp and remove it.
For example, the failed backup session was created 2020-09-01:
SELECT * FROM tasks WHERE dump LIKE '%2020-09-01%;
Examine the query output, and remove the which has the session timestamp matching the stuck one in GUI:
DELETE FROM tasks WHERE id=2;