Symptoms
- A backup task in Plesk > Tools & Settings > Backup Manager is running for a long time and not completing
- The backup is being uploaded to an Amazon S3 bucket (backups done via the DigitalOcean Spaces Backup extension also go to S3 buckets)
- Other backup processes targeted towards the same Amazon S3 bucket begin before the current one has been finalized
Cause
During a network issue, the backup process neither terminates, nor allows for subsequent attempts to upload the data towards the S3 bucket to proceed.
This is caused by Plesk Migrator bug #EXTPLESK-4478
Resolution
Until the bug is fixed, the following workaround can be applied:
-
Connect to the server via SSH
-
Kill the stuck backup tasks:
#
kill -9 `ps auxfw | grep -i pmm | grep -v grep | awk {'print $2'}`
#kill -9 `ps auxfw | grep -i backup | grep -v grep | awk {'print $2'}`
During the next execution of a backup (regardless of whether it is manual or scheduled), the stuck backup issue should not present itself, as long as the connection to the Amazon S3 bucket remains stable throughout the whole backup process