Symptoms
-
An operation in Plesk fails with the error message:
Unable to lookup SID for name IUSR_example.com: (1332) No mapping between account names and security IDs was done.(Error code 1)
-
A Plesk backup task fails with the error message:
Unable to back up files from C:Inetpubvhostsexample.com owned by system user. Error: Failed to create archive: Unknown error
Warning: Subscription "example.com"
Unable to back up files from C:Inetpubvhostsexample.com owned by system user. Error: Failed to create archive: Repository error: Archiver error: unable to pack C:/Inetpub/vhostsexample.com. Unable to logon system user 'jdoe' (domain: '') to impersonate. Using password: yes. Details: The user name or password is incorrect.. -
Migration finishes with the following warning:
Can not deploy web-content of domain example.comWarning:ForeignMigratorCore.MigratorException: System.Exception: Get flags failed of user (IUSR_example.com): (2221) The user name could not be found.
-
When changing permissions in Plesk File Manager, the operation fails with the following error message:
PleskUtilException
filemng failed: The user name could not be found. (Error code 2221) at NetUserGetInfo((null), john) at (UserInformation::getUserInformation line 187) at getUserInformation(john)(UserInformation::getUserInformation line 193) at execute "D:Program Files (x86)ParallelsPleskadminbinfilemng" john --permissions --list-common "--file=D:Webvhostsexample.comhttpdocswordpresswp-content" "--accounts=fsgF93A.tmp"(RunTime::RunAsUser::run line 223) (Error code 1)
Cause
The user mentioned in the error message does not exist in the local system.
Resolution
-
Connect to the server via RDP.
-
Apply the solution for all or several domains:
For all domains
Run the following commands to fix all domains:
C:> "%plesk_cli%/repair" --repair-all-webspaces-system-users
C:> "%plesk_cli%/repair" --regenerate-web-server-users-password
C:> "%plesk_dir%binrepair.exe" --repair-all-webspaces-security
C:> "%plesk_cli%/repair" --synchronize-impersonation-storage
For one or several domains
If one or several domains are affected, use the following commands:
C:> "%plesk_cli%/repair" --repair-webspace-system-users -webspace-name example.com
C:> "%plesk_cli%/repair" --repair-webspace-security -webspace-name example.com
C:> "%plesk_cli%/repair" --synchronize-impersonation-storage