Plesk

A user is being logged out from Plesk periodically or Plesk redirects to the login page after a successful login attempt

Symptoms

Cause

User's IP address is changed during a Plesk session. This may happen if user's IP address is dynamic or the domain/hostname which is used as a URL for Plesk is behind Cloudflare.

By default, Plesk does not allow IP address changes during a single session.

Resolution

Allow IP address changes during a single session:

  1. Log in to Plesk (use the server IP address if it is not possible to log in using the hostname).

  2. Go to Tools & Settings > Session Idle Time and enable the option Allow IP address changes during a single session.

  3. Click OK to apply the changes.

 

Command-line instructions

 

  1. Connect to the Plesk server via SSH (Linux) / RDP (Windows Server).
  2. Run the following command to enable IP address changes during a single session (on Windows Server, start a command prompt as an Administrator):

    # plesk bin settings --set disable_check_session_ip=true

 

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