When updating Plesk or system packages via Plesk, the process fails with the error message:
2017-01-01 00:00:00 INFO: pum is
called with arguments: ['--update', '--json',
'--', 'binutils', 'dnsmasq', 'docker-engine',
'initscripts', 'iptables', 'kexec-tools',
'libgomp', 'microcode_ctl', 'net-snmp',
'plesk-git-http', 'polkit', 'tuned', 'wget',
2019-11-01 00:22:46 ERROR: [u'ERROR with transaction check vs depsolve:', 'systemd = 219-67.el7_7.2 is needed by (installed) systemd-sysv-219-67.el7_7.2.x86_64', 'systemd = 219-67.el7_7.2 is needed by (installed) systemd-sysv-219-67.el7_7.2.x86_64', 'firewalld-filesystem = 0.6.3-2.el7_7.2 is needed by firewalld-0.6.3-2.el7_7.2.noarch', 'python-firewall = 0.6.3-2.el7_7.2 is needed by firewalld-0.6.3-2.el7_7.2.noarch', 'device-mapper-event-libs = 7:1.02.158-2.el7_7.2 is needed by (installed) device-mapper-event-7:1.02.158-2.el7_7.2.x86_64', 'device-mapper-event-libs = 7:1.02.158-2.el7_7.2 is needed by (installed) device-mapper-event-7:1.02.158-2.el7_7.2.x86_64']
2019-11-01 00:22:46 ERROR: Exited with returncode 1.
ERROR: Your package system contains duplicated packages, which can lead to broken Plesk update:
Websites & Domains > System Overview > Check for Updates > Install Updates:
Warning: Information on some packages might not be actual: inconsistencies were detected in the system's package manager database. Please resolve this issue manually.
The following error message appears in
/var/log/plesk/panel.log, where <package_name1> and <package_name2> can be any package name:
ERROR: Exited with returncode 1.
ERR [panel] Task failed: id=19, pid=39949, type=pum-update-packages, error=2018-02-08 INFO: pum is called with arguments: ['--update', '--json', '--', <package_name1>, <package_name2>, ...]
INFO: updating packages: <package_name1>, <package_name2>, ...
ERROR: Test Transaction Errors: package <package_name1>-2.0.14-17.2.el7.x86_64 (which is newer than <package_name1>-2.0.14-17.el7.x86_64) is already installed
package <package_name2>-2.8.0-5.el7_4.2.noarch (which is newer than <package_name2>-2.8.0-5.el7.noarch) is already installed
When updating the packages manually with the command
yum update, the process fails due to package duplicates with the following error messages:
Error: Package: 1:<package_name1>-1.0.6-31.el7_2.x86_64 (@updates)
Requires: <package_name1>-libnm(x86-64) = 1:1.0.6-31.el7_2
Installed: 1:<package_name1>-libnm-1.8.0-11.el7_4.x86_64 (@updates)
<package_name1>-libnm(x86-64) = 1:1.8.0-11.el7_4
Available: 1:<package_name1>-libnm-1.8.0-9.el7.x86_64 (base)
<package_name1>-libnm(x86-64) = 1:1.8.0-9.el7
You could try using --skip-broken to work around the problem
** Found 47 pre-existing rpmdb problem(s), 'yum check' output follows:
<package_name2>-5.6.27-centos7.16101710.x86_64 has missing requires of <package_name2> = ('0', '5.6.27', 'centos7.16101710')
<package_name2>-5.6.33-centos7.18010913.x86_64 is a duplicate with <package_name2>-5.6.27-centos7.16101710.x86_64
Duplicated packages in the RPM database.
Note: The cause of this behavior is related to the incorrect operations that are done by the system's utility
yum. Sometimes, the packages…