Plesk

WordPress can not be installed via WP Toolkit in Plesk: Specified column “guid” is not in the row

Symptoms

Cause

Corrupted WP Toolkit SQLite database.

Resolution

Add missing column to WP Toolkit database:

For Plesk Linux

  1. Connect to the server via SSH

  2. Create a backup of the SQLite3 database:

    # cp /usr/local/psa/var/modules/wp-toolkit/wp-toolkit.sqlite3 /usr/local/psa/var/modules/wp-toolkit/wp-toolkit.sqlite3.bak

  3. Access the SQLite3 database:

    # sqlite3 /usr/local/psa/var/modules/wp-toolkit/wp-toolkit.sqlite3

  4. Update the table Instances

    # sqlite> ALTER TABLE Instances ADD COLUMN guid VARCHAR(36) NULL;

  5. Disconnect from the SQLite database:

    # sqlite> .q

For Plesk Windows

  1. Connect to the server via RDP

  2. Create a backup of the original database at %plesk_dir%varmoduleswp-toolkitwp-toolkit.sqlite3

  3. Open a command-line window and access the database using the SQLite3 utility with the following command:

    C:> "%plesk_bin%sqlite3" "%plesk_dir%varmoduleswp-toolkitwp-toolkit.sqlite3"

  4. Update the table Instances:

    C:> sqlite> ALTER TABLE Instances ADD COLUMN `guid` VARCHAR(36) NULL;

  5. Disconnect from the SQLite database:

    C:> sqlite> .q

Note: In case the resolution above does not fix the issue remove the extension WP Toolkit and install it again.