Plesk

Webserver Configurations Troubleshooter detects extra configuration or shows a false positive report on the Home page

Symptoms

Cause

The Plesk database contains records about non-existent configuration files or old error messages.

Resolution

Remove the old information via Plesk:

  1. Log in to Plesk.

  2. Go to Tools & Settings > Webserver Configurations Troubleshooter.

    Note: If the Webserver Configurations Troubleshooter option is not shown, install it following the instructions available in this KB article.

  3. Click the button > Set Status search filter to Error from the drop-down menu:

  4. The list of broken configuration files will appear. Select all, then click Rebuild > Selected.

  5. If configuration files could not be repaired, select them and click Remove.

  6. Click Check configuration to make sure there is no broken configuration left.

 

Removing the old information via SSH connection

 

  1. Connect to the Plesk server via SSH.

  2. Create a folder for temporary files:

    # mkdir -p /tmp/plesksupport

  3. Create a file with affected domains:

    # MYSQL_PWD=`cat /etc/psa/.psa.shadow` mysql -uadmin psa -Ne"select name from domains where id in (select objectId from Configurations where status<>'ok')" > /tmp/plesksupport/domainlist.txt

  4. Reconfigure the affected domains:

    # cat /tmp/plesksupport/domainlist.txt | while read domain; do plesk repair web -y $domain; echo "$domain - success"; done

    # plesk repair web -server

  5. Remove broken configuration entries from the Plesk database:

    # plesk db "delete from Configurations where status <> 'ok'G"

  6. Validate configuration files:

    # plesk repair web -validate-configuration

 

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