Plesk

Unable to setup the Hard Disk quota for a domain: field is greyed-out, hard disk quota is not supported due to configuration of server file system

Symptoms

Cause

Unconfigured disk quota on operating system level.

Resolution

Warning: configuring of the disk quota on the operating system is an administrative task and is not supported by Plesk.
All actions below are the common steps and performed at own risk.

Note: hard disk quota setup depends on the filesystem. In the example below, the steps are performed for ext3 and xfs filesystems, while on another filesystem actions will differ.

For ext3 filesystem:

  1. Connect to the server via SSH.

  2. Make sure that the quota is supported by the kernel. It should be compiled into the kernel or loaded as a module.

    To check if the quota is configured properly use this command:

    # /usr/local/psa/admin/sbin/usermng --isquotable

    Normally, it should return the "0" value.

    If the utility returns the following error message:

    usermng: Unable to turn on user quota. User quota not supported on device '/dev/sda3'
    System error 3: No such process

    OR

    usermng: Userquota is not enabled on device: /dev/mapper/centos-root

    then enable quota in the /etc/fstab file for the partitions on which Plesk stores data on, e.g. as follows:

    /dev/hda1 / ext3 defaults,usrquota 1 1

  3. Remount the partition:

    # mount -o remount /

  4. Create, check and repair quota files (if utility is missing, install it):

    # /sbin/quotacheck -cfmvF vfsv0 /

    Note: If the command is unknown, install quota package.

  5. Update the user quota with this command line:

    # quotaon /dev/hda1

  6. Make sure that the aquota format is used.

    There should be an aquota.user file in the root of every partition where the quota is enabled.

    If there is the quota.user file remove it and create correct one:

    Note: change the "/dev/hda1" device in commands below to the correct one.

    # rm -f…

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