Skip to content
  • Solutions
    By Role
    • For Developers
    • For Content Managers
    • For Agencies
    • For IT Admins
    • For Web Hosters
    • For Developers
    • For Content Managers
    • For Agencies
    • For IT Admins
    • For Web Hosters
    By Infrastructure
    • Overview
    • AWS
    • Microsoft Azure
    • Alibaba Cloud
    • Google Cloud Platform
    • Vultr
    • Overview
    • AWS
    • Microsoft Azure
    • Alibaba Cloud
    • Google Cloud Platform
    • Vultr
    • Digital Ocean
    • Linode
    • Upcloud
    • Oracle
    • OVH
    • Digital Ocean
    • Linode
    • Upcloud
    • Oracle
    • OVH
  • Product
    • Plesk Features
    • Plesk Editions
    • What’s new
    • Pricing
    • Roadmap
    • Lifecycle Policy
    • Extensions Catalogue
  • Pricing
  • Extensions
    Featured Extensions
    • SocialBee
    • WP Toolkit
    • Sitejet Builder for Plesk
    • SEO Toolkit
    • Joomla! Toolkit
    • Premium Email
    • Email Security
    • SocialBee
    • WP Toolkit
    • Sitejet Builder for Plesk
    • SEO Toolkit
    • Joomla! Toolkit
    • Premium Email
    • Email Security
    Bundles and packs:
    • Business and Collaboration Edition
    • WP pack
    • Hosting pack
    • Power pack
    • Language pack
    • Business and Collaboration Edition
    • WP pack
    • Hosting pack
    • Power pack
    • Language pack

    See all Extensions

  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
  • Pricing
  • Solutions
    • By Role
      • For Developers
      • For Content Managers
      • For Agencies
      • For IT Admins
      • For Web Hosters
    • By Infrastructure
      • Overview
      • Plesk on Amazon Web Services (AWS & Lightsail)
      • Microsoft Azure
      • Alibaba Cloud
      • Google Cloud Platform
      • Vultr
      • DigitalOcean
      • Linode
      • UpCloud
      • Oracle
      • OVH
  • Products
  • Pricing
  • Extensions
    • Featured Extensions
      • SocialBee
      • WP Toolkit
      • Sitejet Builder for Plesk
      • SEO Toolkit
      • Joomla! Toolkit
      • Premium Email
      • Email Security
    • Bundles and packs:
      • Business and Collaboration Edition
      • WP pack
      • Hosting pack
      • Power pack
      • Language pack
      • See all Extensions
  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate Program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
  • Pricing
  • Solutions
    • By Role
      • For Developers
      • For Content Managers
      • For Agencies
      • For IT Admins
      • For Web Hosters
    • By Infrastructure
      • Overview
      • Plesk on Amazon Web Services (AWS & Lightsail)
      • Microsoft Azure
      • Alibaba Cloud
      • Google Cloud Platform
      • Vultr
      • DigitalOcean
      • Linode
      • UpCloud
      • Oracle
      • OVH
  • Products
  • Pricing
  • Extensions
    • Featured Extensions
      • SocialBee
      • WP Toolkit
      • Sitejet Builder for Plesk
      • SEO Toolkit
      • Joomla! Toolkit
      • Premium Email
      • Email Security
    • Bundles and packs:
      • Business and Collaboration Edition
      • WP pack
      • Hosting pack
      • Power pack
      • Language pack
      • See all Extensions
  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate Program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
Plesk 360 login
Free Trial

Knowledge Base

Unable to open/rename file in File Manager on Plesk server: Access denied

 
domainsfile managerfile permissionsinternal server errorphp

Symptoms

  • Cannot open PHP Info page atDomains > example.com > PHP Settings > View the phpinfo() page:

    Server Error
    500
    PleskUtilException
    Access denied

  • Unable to install Let's Encrypt certificate for a domain in Plesk with error below:

    Status: 403
    Detail: The key authorization file from the server did not match this challenge

  • Website may be inaccessible with:

    500 external server error

  • One of the errors below can be observed with Plesk File Manager:

    • Cannot change file permissions at Domains > example.com > File Manager:

      filemng failed: Unable to get the object (C:Inetpubvhostsexample.comhttpdocspathfile) security info: (5) Access is denied.

    • Unable to access file or directory in File Manager with the following error:

      Unable to open the directory: Unable to find the directory C:Inetpubvhostsexample.comhttpdocs: Access denied

    • Unable to create zip archive in File Manager:

      Unable to create the archive: 7-Zip [32] 16.04
      %plesk_vhosts%example.comhttpdocsarchive.zip
      Items to compress: 14161 WARNING: Access is denied
      WARNING: Cannot open 13 files at (CreateZip::onRunAsUser line 2783).

    • Unable to rename/create file(or directory)/access domain's document root in File Manager with the following error:

      Unable to find the directory C:Inetpubvhostsexample.com: Access denied

    • 'Change Permissions' option in File Manager shows all the boxes are unmarked for the subscription system user, the permissions get automatically reset

Cause

The system user does not have permissions to access subscription directories or incorrect security settings in %plesk_vhosts%example.com.plesk.Security file.

Resolution

  1. Connect to the server using RDP.

    Note: if direct RDP access to the server is not possible, contact server administrator for further assistance.

  2. Rename the .Security file to .Security.bak in %plesk_vhosts%example.com.plesk directory.

  3. Open Command Prompt as Administrator and execute the following command:

    C:> "%plesk_cli%repair.exe" --repair-webspace-security -webspace-name example.com -all-filesystem-objects

  4. If there is %plesk_dir%etcDiskSecuritypermissions.xml file for customizing permissions, review the file and remove the folders of the domain in question

Tweet
Share
Share
Email
0 Shares
Read the full article
Related Posts

Extended Lifecycle Support OSes Update

Read More »

WordPress 500 Internal Server Error: What to do

Read More »

Ruby on Rails vs PHP: Which one’s right for your needs?

Read More »
Knowledge Base

Unable to manage, create ZIP or back up files uploaded by PHP scripts in Plesk: Unable to get the object security info: (5) Access is denied

Read More »

Unable to open log of particular domain in Plesk: Internal error: Unable to open log file

Read More »

Unable to log in to Plesk or upload files via Plesk File Manager or applications: The file is too big

Read More »

Unable to open Logs or File Manager for domain in Plesk: 500 PleskUtilException Access Denied

Read More »

Hosting Wiki

  • Content Security Policy ( CSP )
  • Server Redundancy
  • Bare Metal Server
  • SSI
  • PhpMyAdmin
  • phpPgAdmin
  • Oracle VM Server
  • Server Virtualization Software
  • Windows Server
  • PHP
  • Domain
  • Plesk
  • Web Server
  • DNS Server
X-twitter Linkedin Youtube Reddit Github
  • Product
  • Login
  • Pricing
  • Editions
  • For Partners
  • Partner Program
  • Contributor Program
  • Affiliate Program
  • Plesk University
  • Company
  • Blog
  • Careers
  • Events
  • About Plesk
  • Our Brand
  • Resources
  • User and Admin guides
  • Help Center
  • Migrate to Plesk
  • Contact Us
  • Hosting Wiki
  • Forum
  • Legal
  • Legal
  • Privacy Policy
  • Imprint

© 2025 WebPros International GmbH

Part of the WebPros®  Family