Symptoms
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An attempt to perform one of the following operations in Plesk might fail:
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Creating a Subscription
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Changing the password of the main Subscription system user in example.com > Web Hosting Access
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Deploying an application (e.g., WordPress)
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Settings Permanent SEO-safe 301 redirect from HTTP to HTTPS at Plesk > Domains > example.com > Hosting settings
The operation fails might show the following error:
PLESK_ERROR: Error: no secure shell available
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FileÂ
/usr/local/psa/admin/conf/site_isolation_settings.ini
is modified and contains pre-defined shell:# egrep “shell.*=” /usr/local/psa/admin/conf/site_isolation_settings.ini
shell = /bin/bash -
Plesk detects all the shells correctly:
# plesk sbin sysinfo getshell
/bin/false
/bin/sh
/bin/bash
/usr/bin/sh
/usr/bin/bash
/usr/local/psa/bin/chrootsh /bin/bash (chrooted)
Cause
The configuration set in the file /usr/local/psa/admin/conf/site_isolation_settings.ini
 are overriding the settings configured at the Service Plan level.
Resolution
Note: The solution described in this article needs to be applied by the Plesk server administrator via SSH. If server access is not possible, please contact the service provider.
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Connect to the server via SSH
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Back up the configuration fileÂ
/usr/local/psa/admin/conf/site_isolation_settings.ini
:# cp -a /usr/local/psa/admin/conf/site_isolation_settings.ini{,.backup}
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Comment out the forced
shell
parameter from the configuration file/usr/local/psa/admin/conf/site_isolation_settings.ini
:# sed -i.bak ‘s/shell.*=/;shell =/g’ /usr/local/psa/admin/conf/site_isolation_settings.ini
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Control the SSH access permissions in the corresponding Service Plan or per-subscription:
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Service Plan: Log in to Plesk GUI > Service Plans > Service Plan Name > Permissions > Management of access to the server over SSHÂ > Can allow access only to a chrooted environment or Can allow access to any type of shell > Update & Sync
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Subscription: Log in to Plesk GUI > Subscriptions > example.com > Customize (Right-sidebar) > Permissions > Management of access to the server over SSHÂ > Can allow access only to a chrooted environment or Can allow access to any type of shell > Update &Â Lock
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In case the issue persists, enable the Setup of potentially insecure web scripting options that override provider’s policy option in the corresponding Service Plan or per-subscription:
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Service Plan: Log in to Plesk GUI > Service Plans > Service Plan Name > Permissions > Enable Setup of potentially insecure web scripting options that override provider’s policy option > Update & Sync
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Subscription: Log in to Plesk GUI > Subscriptions > example.com > Customize (Right-sidebar) > Permissions > Enable Setup of potentially insecure web scripting options that override provider’s policy option > Update & Lock
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