Plesk

Some actions fail in Plesk UI: Unable to start C:Program Files (x86)Pleskadminbinfilemng

Symptoms

Cause

The binary from the error message - %plesk_bin%filemng.exe or %plesk_bin%phpcfg.exe - is missing or corrupted.

Resolution

  1. Log in to Plesk.

  2. Go to Tools & Settings > Updates and install the latest updates. The binary %plesk_bin%filemng.exe will be reinstalled.

  3. If does not help or if there are no updates availalbe, unpack the package plesk-backend.msi from C:ParallelsInstaller...PLESK-WIN_XX.X.XXdist-windows or C:ProgramDataPleskInstaller...PLESK-WIN_XX.X.XXdist-windows and put the binary from it to %plesk_bin%, for example:

    C:> msiexec /a C:ProgramDataPleskInstallercachepoolreleasePLESK-WIN_18.0.38_7167dist-windowsplesk-backend.msi /qb TARGETDIR=C:tempMSI

    Note: the package with the binary will be unpacked to C:tempMSI