Skip to content
  • Solutions
    By Role
    • For Developers
    • For Content Managers
    • For Agencies
    • For IT Admins
    • For Web Hosters
    • For Developers
    • For Content Managers
    • For Agencies
    • For IT Admins
    • For Web Hosters
    By Infrastructure
    • Overview
    • AWS
    • Microsoft Azure
    • Alibaba Cloud
    • Google Cloud Platform
    • Vultr
    • Overview
    • AWS
    • Microsoft Azure
    • Alibaba Cloud
    • Google Cloud Platform
    • Vultr
    • Digital Ocean
    • Linode
    • Upcloud
    • Oracle
    • OVH
    • Digital Ocean
    • Linode
    • Upcloud
    • Oracle
    • OVH
  • Product
    • Plesk Features
    • Plesk Editions
    • What’s new
    • Pricing
    • Roadmap
    • Lifecycle Policy
    • Extensions Catalogue
  • Pricing
  • Extensions
    Featured Extensions
    • SocialBee
    • WP Toolkit
    • Sitejet Builder for Plesk
    • SEO Toolkit
    • Joomla! Toolkit
    • Premium Email
    • Email Security
    • SocialBee
    • WP Toolkit
    • Sitejet Builder for Plesk
    • SEO Toolkit
    • Joomla! Toolkit
    • Premium Email
    • Email Security
    Bundles and packs:
    • Business and Collaboration Edition
    • WP pack
    • Hosting pack
    • Power pack
    • Language pack
    • Business and Collaboration Edition
    • WP pack
    • Hosting pack
    • Power pack
    • Language pack

    See all Extensions

  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
  • Pricing
  • Solutions
    • By Role
      • For Developers
      • For Content Managers
      • For Agencies
      • For IT Admins
      • For Web Hosters
    • By Infrastructure
      • Overview
      • Plesk on Amazon Web Services (AWS & Lightsail)
      • Microsoft Azure
      • Alibaba Cloud
      • Google Cloud Platform
      • Vultr
      • DigitalOcean
      • Linode
      • UpCloud
      • Oracle
      • OVH
  • Products
  • Pricing
  • Extensions
    • Featured Extensions
      • SocialBee
      • WP Toolkit
      • Sitejet Builder for Plesk
      • SEO Toolkit
      • Joomla! Toolkit
      • Premium Email
      • Email Security
    • Bundles and packs:
      • Business and Collaboration Edition
      • WP pack
      • Hosting pack
      • Power pack
      • Language pack
      • See all Extensions
  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate Program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
  • Pricing
  • Solutions
    • By Role
      • For Developers
      • For Content Managers
      • For Agencies
      • For IT Admins
      • For Web Hosters
    • By Infrastructure
      • Overview
      • Plesk on Amazon Web Services (AWS & Lightsail)
      • Microsoft Azure
      • Alibaba Cloud
      • Google Cloud Platform
      • Vultr
      • DigitalOcean
      • Linode
      • UpCloud
      • Oracle
      • OVH
  • Products
  • Pricing
  • Extensions
    • Featured Extensions
      • SocialBee
      • WP Toolkit
      • Sitejet Builder for Plesk
      • SEO Toolkit
      • Joomla! Toolkit
      • Premium Email
      • Email Security
    • Bundles and packs:
      • Business and Collaboration Edition
      • WP pack
      • Hosting pack
      • Power pack
      • Language pack
      • See all Extensions
  • For Partners
    • Plesk Contributor Program
    • Plesk Partner Program
    • Affiliate Program
    • Plesk University
  • Help Center
    • Documentation
    • Professional Services
    • Support
    • Contact Us
    • Wiki
    • Forum
  • Plesk 360 login
  • Free Trial
Plesk 360 login
Free Trial

Knowledge Base

RAM value is not calculated in the Plesk Repair Kit: Repair action ‘repairmng.exe –get-system-resources’ execution failed

 
plesk for windowsplesk repairplesk service interfacerepair kitsecurity

Symptoms

  • RAM is not calculated in the Repair Kit. The following error is provided instead under the RAM section:

    Can not retrieve information about memory usage:
    Completed only 0 of 4 bytes at (Con::OverlappedPipe::externalComplete line 392) at Unable to call readMessage() (RunTume::PipeClient::readMessage line 122) at execUtil("C:Program Files (x86)Pleskadminbin64repairmng.exe" --get-system-resources) (PleskRepair::DefaultSystemHelper::execUtil line 45) at Repair action 'repairmng.exe --get-system-resources' execution failed(PleskRepair::ExecUtilAction::execute line 33)

Cause

Corrupted repairmng.exe file.

Resolution

  1. Connect to the server via RDP.

  2. For security reasons copy the current C:Program Files (x86)Pleskadminbin64repairmng.exe file to any directory, for example, to the Desktop.

  3. Create a temporary directory on a Desktop named 'Backend'. Its full path will be: C:UsersAdministratorDesktopBackend.

  4. Start the Command prompt.

  5. Switch to the directory where Plesk MSIs are stored. It's located in C:ProgramDataPleskInstaller... or in C:ParallelsInstaller....
    Select the latest version of Plesk available in the directory. The command should be like below:

    C:> cd C:ProgramDataPleskInstallercachepoolreleasePANEL-WIN_18.0.XXdist-windows

  6. Unpack the plesk-backend.msi from this directory to the temporary folder created on step 3:

    C:> msiexec /a plesk-backend.msi /qb TARGETDIR=C:UsersAdministratorDesktopBackend

  7. Replace the original C:Program Files (x86)Pleskadminbin64repairmng.exe file with the one from the unpacked MSI C:UsersAdministratorDesktopBackendProgram FilesParallelsPleskadminbin64repairmng.exe:

    C:> copy "C:UsersAdministratorDesktopBackendProgram FilesParallelsPleskadminbin64repairmng.exe" "C:Program Files (x86)Pleskadminbin64repairmng.exe"

Tweet
Share
Share
Email
0 Shares
Read the full article
Related Posts

Securing the WordPress Frontier with WP Guardian

Read More »

Introducing WP Guardian Vulnerability Protection: Now available for WP Toolkit

Read More »

What is Cloudflare and How To Set It Up For Your Site?

Read More »
Knowledge Base

Unable to open Logs or File Manager for domain in Plesk: 500 PleskUtilException Access Denied

Read More »

Diagnose & Repair tool provides the error when repairing Plesk installation: 500: PleskExpectionDatabase

Read More »

Error while creating a domain: A specified logon session does not exist. It may already have been terminated.

Read More »

How to free up disk space on a Plesk for Windows server

Read More »

Hosting Wiki

  • Content Security Policy ( CSP )
  • Server Redundancy
  • Bare Metal Server
  • Oracle VM Server
  • Server Virtualization Software
  • Windows Server
  • Plesk
  • Web Server
  • DNS Server
X-twitter Linkedin Youtube Reddit Github
  • Product
  • Login
  • Pricing
  • Editions
  • For Partners
  • Partner Program
  • Contributor Program
  • Affiliate Program
  • Plesk University
  • Company
  • Blog
  • Careers
  • Events
  • About Plesk
  • Our Brand
  • Resources
  • User and Admin guides
  • Help Center
  • Migrate to Plesk
  • Contact Us
  • Hosting Wiki
  • Forum
  • Legal
  • Legal
  • Privacy Policy
  • Imprint

© 2025 WebPros International GmbH

Part of the WebPros®  Family