Plesk

Plesk is not working after the upgrade: Specified column “status” is not in the row

Symptoms

Cause

Plesk database inconsistency, possibly during a failed database upgrade.

Resolution

Restore Plesk database from a pre-upgrade dump and run plesk repair utility to fix other conflicts:

  1. Connect to the server via SSH.

  2. Create a backup of Plesk database:

    # plesk db dump > psa.current.sql

  3. Switch to the directory with pre-upgrade dumps:

    # cd /var/lib/psa/dumps

  4. List all available pre-upgrade dumps:

    # ls -l mysql.preupgrade*
    -rw------- 1 root root 221821 May 4 18:03 mysql.preupgrade.18.0.25-18.0.26.20200504-180302.dump.gz
    -rw------- 1 root root 236912 May 24 14:02 mysql.preupgrade.18.0.26-18.0.27.20200524-140248.dump.gz

    In the example below, we are restoring all system databases from a dump file that was created before an upgrade from Plesk Obsidian 18.0.26 to 18.0.27:

  5. Restore system databases:

    # zcat mysql.preupgrade.18.0.25-18.0.26.20200504-180302.dump.gz | MYSQL_PWD=`cat /etc/psa/.psa.shadow` mysql -uadmin

  6. Run Plesk repair installation to fix possible database version conflicts:

    # plesk repair installation