Symptoms
-
Plesk is not accessible:
HTTP Error 500.0 - Internal Server Error
C:Program Files (x86)Pleskadminenginephp-cgi.exe - The FastCGI process exited unexpectedly -
If try accessing Plesk directly on the server while connected to it over RDP, the following detailed information is shown:
Detailed Error Information:
Module FastCgiModule
Notification ExecuteRequestHandler
Handler PleskEngine-FastCGI-php
Error code 0x00000000
Requested URL https://localhost:8443/index.php
Physical Path C:Program Files (x86)Pleskadminhtdocsindex.php
Logon Method Anonymous
Logon User Anonymous -
The application pool
PleskControlPanel
and the sitepleskcontrolpanel
are started in IIS. -
Repairing Plesk site using Plesk Reconfigurator does not help as well.
Cause
PHP which is used for serving Plesk site (located in the directory %plesk_dir%adminengine
) is corrupted.
Resolution
-
Connect to the server using RDP.
-
Back up the directory
%plesk_dir%adminengine
. -
Locate the necessary MSI file which contains Plesk’s PHP files.
For example, for Plesk Onyx 17.5.3 this file is
C:ParallelsInstallerparallelsPANEL-WIN_17.5.3dist-msi-Microsoft-2003-i386plesk-engine_mu028.msi
.Alternatively, the file can be called just
plesk-engine.msi
. -
Create a directory for extracting the files from MSI (for example,
C:tempMSI
). -
Unpack the MSI file found in step 3:
C:> msiexec /a C:ParallelsInstallerparallelsPANEL-WIN_17.5.3dist-msi-Microsoft-2003-i386plesk-engine_mu028.msi /qb TARGETDIR=C:tempMSI
-
Copy all files from the directory
C:tempMSIProgram FilesParallelsPleskadminengine
to the directory%plesk_dir%adminengine
with replacing the already existing files.