Plesk

[BUG] Scheduled backups to Dropbox extension fail on Plesk server: too many requests

Symptoms

Dropbox scheduled backups fail with the following error on Plesk server:

INFO: TransportError Transport error: Extension transport: ext://dropbox-backup/server/: {"error_summary": "too_many_requests/.", "error": {"reason": {".tag": "too_many_requests"}, "retry_after": 15}} [common/plesk-utils/PMM/repository-transport/repository_transport_external.cpp:TransportError]

Cause

Bug with ID #EXTPLESK-2471 which is already fixed.

Resolution

Update Dropbox Backup Extension to the latest version.

If update is not possible for some reason, use the following workaround:

Click on a section to expand

Workaround:

  1. Log in to Plesk
  2. Go to Extensions > My Extensions and remove Dropbox extension
  3. Install Panel.ini extension
  4. Go to Extensions > My extensions > Panel.ini editor > Edit
  5. Add the following at the end of the document to have ability upload extensions manually:

    [ext-catalog]
    extensionUpload = true

  6. Download attached .zip file 
  7. Go to Extensions > My extensions > press Upload Extension button and select file from step 6:
  8. Configure again scheduled backups to Dropbox with your account.