Plesk

An operation in Plesk fails: Unable to lookup SID for name

Symptoms

Cause

The user mentioned in the error message does not exist in the local system.

Resolution

  1. Connect to the server via RDP.

  2. Start a command prompt as an Administrator.

  3. Apply the solution for all or several domains:

For all domains

Run the following commands to fix all domains:

C:> "%plesk_cli%/repair" --repair-all-webspaces-system-users

C:> "%plesk_cli%/repair" --regenerate-web-server-users-password

C:> "%plesk_dir%binrepair.exe" --repair-all-webspaces-security

C:> "%plesk_cli%/repair" --synchronize-impersonation-storage

For one or several domains

If one or several domains are affected, use the following commands:

C:> "%plesk_cli%/repair" --repair-webspace-system-users -webspace-name example.com

C:> "%plesk_cli%/repair" --repair-webspace-security -webspace-name example.com

C:> "%plesk_cli%/repair" --synchronize-impersonation-storage

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