Plesk

A website is inaccessible when ModSecurity is enabled: Failed deleting collection (name “ip”, key “xxxxx”): Internal error

Symptoms

Cause

Huge ip.pag file from Modsecurity causing a timeout.

Resolution

Solution for Linux

  1. Log in to Plesk

  2. Go to Tools & Settings > Web Application Firewall (ModSecurity) > Settings tab

  3. Under Custom directives, add the directive SecCollectionTimeout 600 (default is 3600), then click Apply to save the settings:

  4. Go to the General tab in the Web Application Firewall.

  5. Under the option Web application firewall mode select Off, then click Apply to save the settings

  6. Connect to the server via SSH

  7. Run the following command to clear the ip.pag file:

    # echo "" > /var/cache/modsecurity/www-data-ip.pag

  8. In Plesk, under the option Web application firewall mode select On, then click Ok to apply the settings

Solution for Windows

  1. Log in to Plesk

  2. Go to Tools & Settings > Web Application Firewall (ModSecurity) > Settings tab

  3. Under Custom directives, add the directive SecCollectionTimeout 600 (default is 3600), then click Apply to save the settings:

  4. Go to the General tab in the Web Application Firewall.

  5. Under the option Web application firewall mode select Off, then click Apply to save the settings

  6. Connect to the server via RDP

  7. Open CMD as administrator

  8. Run the command below to find the GUID of the affected domain:

    C:> plesk db "select guid from domains where name like '%example.com%'"
    +--------------------------------------+
    | guid |
    +--------------------------------------+
    | B51D0987-DEC1-415C-8941-6BB5A49D5E7E |
    +--------------------------------------+

  9. Open Windows Explorer and navigate to the folder C:Program Files (x86)PleskModSecurityvhosts<GUID>temp

  10. Empty the file IWPD_3(examplecom)-ip.pag

  11. In Plesk in the General tab in the Web Application Firewall, select On, then click Apply to save the settings