Plesk

Unable to start migration in Plesk: q must be exactly 160, 224, or 256 bits long

Symptoms

Cause

SSH keys required for the migration are not installed properly.

Resolution

Apply one of two possible solutions:

To re-generate SSH keys:

  1. Connect to the target server via SSH.
  2. Re-configure SSH keys as per the guide: Migration Guide: Authentication by SSH (Linux) .
  3. Re-start the migration using the SSH keys authorization.

If the issue still persists, check that the files below have the same permissions on the target and on the source server:

# stat ~/ | grep Access | head -n1

# stat ~/.ssh | grep Access | head -n1

# stat ~/.ssh/authorized_keys | grep Access | head -n1


To change the authorization method from 'SSH keys' to 'User / password':

  1. Log into Plesk.
  2. Go to Tools & Settings > Migration and Transfer manager.
  3. Finish the current migration session by clicking on the Finish Migration.
  4. Confirm clearing all settings.
  5. Press the Start a New Migration button to start a new migration session.
  6. Set Authorization as User / password and specify root user's password.
  7. Adjust other settings.
  8. Press the Prepare migration button to start a new migration session.