Plesk

Unable to activate suspended customer or subscription in Plesk: The subscription is suspended because its subscriber was suspended

Symptoms

Cause

Inconsistency in Plesk database.

Resolution

Note: This article may require additional administrative knowledge to apply. If any help required, contact server’s administrator or hosting support.

  1. Connect to a Plesk server via SSH/RDP.

  2. Create a dump of Plesk database:

    • For Linux:

      # plesk db dump psa > /root/psa_backup.sql

    • For Windows Server:

      C:> plesk db dump psa > C:psa_backup.sql

  3. Access the Plesk database:

    # plesk db

  4. Activate the customer or subscription (replace the John Doe/example.com with actual name):

    • Activating the customer:

      mysql> UPDATE clients SET status=0 WHERE pname='John Doe';

    • Activating the subscription:

      mysql> UPDATE domains SET status=0, webspace_status=0 WHERE name='example.com';

  5. Once done, log in to Plesk, then suspend the customer or subscription from the step 4 and activate it back: