Symptoms
-
Unable to scan PHP Composer application on the primary domain of a subscription:
Could not scan domains for Composer applications: There is no web hosting configured on the domain
-
On a subdomain the message is the following:
The domain was scanned. No applications were found.
-
A domain forwarder is set on the same subscription
Cause
Composer extension bug with ID #EXTPHPCOMP-114 which will be fixed in future extension updates.
Resolution
As a workaround, create domain alias instead, which will also redirect requests in the same way instead of forwarding one.
Note: In this example, the subscription is named example.com and the domain with hosting type Forwarding is named example.net
- Log in to Plesk
- Remove the Domain forwarder at Subscriptions > example.com > example.net > Remove Website
- Add the same domain as an alias at Subscriptions > example.com > Add Domain Alias