Plesk

Migration to Plesk server fails: error 1006: Access to API is disabled

Symptoms

Cause

API is disabled in Plesk configuration file panel.ini
on the target Plesk server.

Plesk Migrator functionality will be reworked to avoid such issues in the scope of the #PMT-2702 request.

Resolution

As a workaround, enable API using the following steps:

  1. Log into Plesk UI.
  2. Install "panel.ini editor" extension using this guide.
  3. Open Plesk > Extensions > My extensions > panel.ini editor:

  4. Using Panel.ini editor extension set option enabled = on under
    [api]
    section.
    If there any other lines under [api] section comment them out :

    [api]
    enabled = on
    ;allowedIPs <--- this line is commented
    ;ip filter  <--- this line is commented

  5. Cancel current migration and start a new migration from scratch.

Additional information

 

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