Symptoms
- Migration to the Plesk server fails with one of the following errors:
Failed to connect to target Plesk server by Plesk API: Plesk error [1006]: Access to API is disabled.
Error: Looks like the migration could not be started. Please check that the specified IP address and the administrator login and password are correct and try again. Refer to logs for details: download info log, download debug log.
Cause
API is disabled in Plesk configuration file panel.ini
on the target Plesk server.
Plesk Migrator functionality will be reworked to avoid such issues in the scope of the #PMT-2702 request.
Resolution
As a workaround, enable API using the following steps:
- Log into Plesk UI.
- Install "panel.ini editor" extension using this guide.
- Open Plesk > Extensions > My extensions > panel.ini editor:
-
Using Panel.ini editor extension set option enabled = on under
section.
[api]
If there any other lines under[api]
section comment them out :[api]
enabled = on
;allowedIPs <--- this line is commented
;ip filter <--- this line is commented - Cancel current migration and start a new migration from scratch.
Additional information
- Migration can not be started: Failed to connect to target Plesk server by Plesk API Plesk error 1006 Access to API is disabled
- Site import or migration cannot be started: ailed to connect to target Plesk server by Plesk API: Plesk error [1006]: Access to API is disabled for 203.0.113.2