Symptoms
-
Plesk Repair Kit is stuck.
-
There are no records in the Plesk database stating that the repair task is in progress:
-
in ModuleSettings
# plesk db "select * from ModuleSettings where name like '%repair_progress%' and value=1;"
# -
in longtasks
# plesk db "select * from longtasks where type='ext-repair-kit-task_repair'G"
#
-
-
There is a repair progress record in the Plesk database:
# plesk db "select * from ModuleSettings where name like '%repair_progress%' and value=1;"
+-----------+-----------------+-------+
| module_id | name | value |
+-----------+-----------------+-------+
| 21 | repair_progress | 1 |
+-----------+-----------------+-------+
Cause
Plesk Repair Kit displays non-actual status of checking/repairing process. This is a Plesk Repair Kit bug with ID EXTPLESK-1414, which will be fixed in future updates.
Resolution
-
Connect to the Plesk via SSH.
-
For security reasons, create a dump of the Plesk database:
# plesk db dump psa > psa.sql
-
Delete the non-actual record from Plesk database:
# plesk db "DELETE FROM ModuleSettings where name like '%repair_progress%' and value=1;"
-
Re-scan the server via Repair Kit.