Symptoms
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Unable to change the service plan for the subscription via Plesk > Subscriptions > Change Plan - the no change value appears in the New Service Plan dropdown menu.
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There are more than one service plans at the Plesk > Service Plans page.
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Subscription belong to a reseller or reseller's customer.
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The corresponding reseller has only one service plan.
Cause
Reseller has only one service plan, thus, it is not possible to select another one service plan for the subscription.
Resolution
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Go to Plesk > Resellers > John Doe | Log In as Reseller > Service Plans.
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Create a new service plan by clicking the corresponding Add a Plan button.
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Go to Plesk > Subscriptions.
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Mark the required subscription(s), click the Change Plan button, select the newly created service plan and press the OK button.