Symptoms
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The error message below is displayed when trying to install a Plesk VPS license on a Windows Server on QEMU KVM on RedHat virtualization platform:
PLESK_ERROR: Error: The license key is invalid. In order to use Plesk, you need to obtain and install a new valid license key. The license key is intended only for use with Plesk operating inside the following virtual environments: Virtuozzo containers, VMWare, Microsoft Hyper-V, Xen, KVM, Virtuozzo Server, LXC, Docker.
-
The php script info.php in this article gives this output:
'platform' => 'dedicated',
Note: if the message This app can’t run on your PC is displayed, it is possible to use this command instead:
C:> “%plesk_dir%adminenginephp.exe” info.php | findstr platform
‘platform’ => ‘dedicated’, -
The command below gives the output “none”:
C:> “%plesk_dir%adminenginephp.exe” -dauto_prepend_file= -r “echo get_virtualization();”
none -
The command below answers Red Hat and KVM as System Manufacturer and Model:
C:> systeminfo | findstr /C:”System Manufacturer” /C:”System Model”
System Manufacturer: Red Hat
System Model: KVM
Cause
Product issues:
-
#PPP-39785 “A VPS license can now be installed on a QEMU KVM server without any issues.”
Fixed in:- Plesk Obsidian 18 December 2018 (Windows)
- #PPPM-9784 Open
Resolution
Workaround
If update is not possible for some reason you may try the following
temporary solution
As a workaround, it is possible to apply the patch attached following these steps:
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Connect to the server via RDP
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Download the archive PPPM-9784-Plesk-17.8.zip.
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Extract it on the server.
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Run Windows command prompt as Administrator
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Stop Plesk Management Service:
C:> net stop “Plesk Management Service”Â
- Run the following 2 commands to create a backup ofÂ
plesksrv.exe
fileC:> cd %plesk_bin%
C:> ren plesksrv.exe plesksrv.exe_backup
-
Copy
plesksrv.exe
 from the extracted archive to the%plesk_bin%
folder -
Start Plesk Management Service again:
C:> net start “Plesk Management Service”Â