Plesk

Plesk DigitalOcean DNS extension is creating records with the duplicated domain name

Symptoms

Cause

Recent changes in DigitalOcean DNS API which led to DigitalOcean DNS extension adding DNS records with the duplicated domain name part.

Resolution

Until the new version of the DigitalOcean DNS extension is released, use the workaround:

  1. Log in to Plesk.
  2. Go to DigitalOcean DNS menu and press the Deactivate all button to disable the synchronization of DNS zones for all domains.
  3. Log in to the Digital Ocean panel and adjust the DNS records there manually by removing the duplicated pert in the DNS records' Hostnames.