Plesk

Domains periodically unavailable for some time: (111: Connection refused) while connecting to upstream

Symptoms

Cause

When a subscription/domain is created Plesk restarts Apache and it causes a temporary downtime of Apache. 

Resolution

Configure Nginx to process all website's content:

  1. Log into Plesk
  2. Navigate to Domains > example.com > Apache & nginx Settings and disable Proxy mode

Warning: If Proxy mode is disabled, Apache rewrite rules and .htaccess files will not be processed. Apache still needs to be installed and running on a server.

Additional information

Apache restarts frequently on Plesk running server: Caught SIGTERM, shutting down