Symptoms
-
The following errors can be found at Domains > example.com > Logs:
[error] 15231#0: *12218 connect() failed (111: Connection refused) while connecting to upstream, client: 203.0.113.2, server: example.com, request: "GET / HTTP/1.1", upstream: "https://192.0.2.2:7081/", host: "www.example.com"
-
Apache graceful restart was enabled according the article How to enable/disable graceful restart for Apache? but errors are still appeared.
-
Apache graceful restart takes few seconds before the new master process is deployed as can be seen in
/var/log/apache2/error_log
or/var/log/httpd/error_log
:[mpm_prefork:notice] [pid 11522] AH00170: caught SIGWINCH, shutting down gracefully
[mpm_prefork:notice] [pid 16650] AH00163: Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips Apache mod_fcgid/2.3.9 configured -- resuming normal operations
Cause
When a subscription/domain is created Plesk restarts Apache and it causes a temporary downtime of Apache.
Resolution
Configure Nginx to process all website's content:
- Log into Plesk
- Navigate to Domains > example.com > Apache & nginx Settings and disable Proxy mode
Warning: If Proxy mode is disabled, Apache rewrite rules and .htaccess
files will not be processed. Apache still needs to be installed and running on a server.
Additional information
Apache restarts frequently on Plesk running server: Caught SIGTERM, shutting down