Symptoms
-
Not possible to configure Outlook or Thunderbird for a domain
example.com
behind Cloudflare. Thunderbird shows the below error:Unable to log in at server. Probably wrong configuration, username or password.
-
Mail settings configured automatically by auto-discover as
example.com
for incoming/outgoing servers.
Cause
By default, Plesk uses a domain name like example.com
for incoming/outgoing mail. When a domain is behind the Cloudflare proxy it forwards only Web traffic and blocks all others including the mail traffic. As a result, an attempt to use example.com
in mail client settings will return an error.
Resolution
One of the following solutions is available:
-
Disable Cloudflare for the domain in the Cloudflare dashboard
-
Configure the mail account manually using
mail.example.com
for incoming/outgoing mail:First, it is required to log in to the Cloudflare dashboard and configure the DNS record for
mail.example.com
.
After that, apply one of the following methods:Plesk GUI method
-
Install the Panel.ini Editor from the Extensions menu in Plesk.
-
Open Panel.ini Editor at Extensions > My Extensions.
-
In Panel.ini Editor, switch to the Editor tab and add the following configuration at the end of the file:
[mail]
clientConfig.incomingServer="mail.<domain>"
clientConfig.outgoingServer="mail.<domain>" -
Apply the changes.