Plesk Requirements – Hardware & Software

Plesk Obsidian is the new generation of the very popular Plesk control panel for website hosts. Plesk Obsidian has numerous advanced features and includes support for the latest tech, including Git, AutoSSL and Docker.

Plesk Hardware Requirements

As any other complex software solution, Plesk Obsidian is dependent on hardware resources.

Plesk Minimum Requirements

  • The minimum amount of RAM required for installing and running Plesk on Linux is 1 GB + 1 GB swap. On Windows – 2 GB of RAM.
  • The minimum amount of free disk space required for installing and running Plesk is 20 GB on Linux and 32 GB on Windows

Plesk Recommended Requirements

For an ordinary shared hosting environment we recommend that you have at least 1GB of RAM per 40 – 50 websites. So, 200 websites would imply Plesk hardware requirements of a minimum of 4GB. We base this recommendation on the following assumptions:

  • On average, shared hosting servers see that about 10% of websites are active, in other words 10% of websites have a persistent level of traffic week in, week out
  • 128MB of RAM will handle most websites. For example:
    • 64MB for WordPress
    • 64MB for Joomla
    • 128MB for Drupal
    • 128MB for Symfony
  • A maximum of 1 to 3 simultaneous visitors for each website, with no more than 500 unique visitors per website on any given day

Websites with higher traffic (for example, 5 to 10 concurrent visitors and a total of 1,000 to 30,000 visitors per day) will require more RAM, in the range of 500MB to 1GB for each website. Also note that Plesk hardware requirements means that you need enough disk space for memory swapping.

Amount of RAM on the server   Recommended free disk space for swapping
Less than 1 GB1 GB
1 GB or more1/2 * the amount of RAM

As concerns disk space – we recommend having this much disk space for hosting:

Type of hostingRecommended free disk space for websites
Typical shared hosting (100-500 websites per server)Between 2 and 2.5 GB per website
Dedicated VPS hosting (1-10 websites per server)Between 4 and 12 GB per website

Plesk Software Requirements

Plesk Obsidian is dependent on operating system and its software environment.

Supported Operating Systems

Plesk Obsidian for Linux can run on the following operating systems:

Ubuntu 22.04 64-bitYesYes

Operating systemSNI supportIPv6 support
Debian 10 64-bitYesYes
Debian 11 64-bitYesYes
Debian 12 64-bitYesYes
Ubuntu 18.04 64-bitYesYes
Ubuntu 20.04 64-bitYesYes
Ubuntu 22.04 LTS for ARM 64-bitYesYes
CentOS 7.x 64-bitYesYes
Red Hat Enterprise Linux 7.x 64-bitYesYes
Red Hat Enterprise Linux 8.x 64-bitYesYes
Red Hat Enterprise Linux 9.x 64-bitYesYes
CloudLinux 7.1 and later 64-bitYesYes
CloudLinux 8.x 64-bitYesYes
AlmaLinux 8 64-bitYesYes
AlmaLinux 9 64-bitYesYes
Rocky Linux 8.x 64-bitYesYes
Virtuozzo Linux 7 64-bitYesYes

Notes:

  • Plesk announces Extended Support for Ubuntu 18.04 until September 2024:
    • Plesk recommends that you begin planning to either dist-upgrade any Ubuntu 18.04 servers with Plesk you may operate, or to migrate hosted websites from them to servers with Plesk running one of the recommended OSes.
    • Plesk continues to accept technical support requests from Plesk Obsidian on supported product versions on Ubuntu 18.04 without any restrictions.
    • Plesk reserves the right to warn Ubuntu 18.04 administrators about risks of an outdated OS using any channels including in-product notifications.
  • To install Plesk Obsidian on Red Hat Enterprise Linux, enable the “Optional” channel.
  • Plesk only supports Debian and Ubuntu servers running the systemd init system. Compatibility with sysvinit has not been tested and is not guaranteed.
  • Plesk supports Debian 11, however, a number of limitations exist. You can use the dist-upgrade procedure to upgrade your OS from Debian 10 to Debian 11.
  • Plesk supports Ubuntu 20.04 and 22.04, however, a number of limitations exist for both version 20.04 and 22.04.
  • Plesk supports Red Hat Enterprise Linux 9 and AlmaLinux 9, however, a number of limitations exist.
  • CentOS, Red Hat Enterprise Linux, and CloudLinux are supported at the latest available minor (.x) versions.
  • You can now in-place convert your Plesk server on CentOS 8 to AlmaLinux 8. To do so, run the script prepared by the AlmaLinux team on your CentOS 8 server.
  • You can now in-place convert your Plesk server on CentOS 8 to Rocky Linux 8. To do so, follow the procedure described in the Rocky Linux documentation.
  • There are a number of operations that cannot be performed in Plesk installed in a Virtuozzo container:
  • Adding IP addresses to and removing them from the server’s network cards.
    • Changing the hostname.
    • Setting the system date and time.
    • Additionally, after adding one or more IP addresses to the Virtuozzo hardware node, you need to use the “Reread IP” function in Tools & Settings > IP Addresses to update the Plesk IP pool.

Plesk Obsidian for Microsoft Windows can run on the following operating systems:

Operating systemSNI supportIPv6 support
Windows Server 2016 (64-bit, Standard, Datacenter, and Essentials editions), including Server Core installations Yes Yes
Windows Server 2019 (64-bit, Standard, Datacenter, and Essentials editions), including Server Core installations Yes Yes
Windows Server 2022 (64-bit, Standard, Datacenter, and Essentials editions), including Server Core installations Yes Yes

 

You must configure a static IP address on the OS before you install Plesk for Windows.

Plesk for Windows only supports NTFS and is an essential element of Plesk software requirements for Windows.

Using Microsoft SQL Server in Plesk for Windows requires that Microsoft SQL Server is configured to use either standard security mode or mixed security mode. If Microsoft SQL Server is not already on your machine, install it while you install Plesk for Windows. It will be configured username “sa” and a password that is randomly chosen.

Plesk Installation Requirements

When installing Plesk, pay attention to the following installation requirements:

CloudLinux Support

Note that link traversal protection on CloudLinux can cause many different Plesk issues. To avoid Plesk issues when link traversal protection is enabled, first disable the fs.protected_symlinks_create kernel option.

Active Directory Domain Controllers Support

We recommend that Plesk is not installed on a server that also acts as either a backup or a primary domain controller. If you do so you may find that the server crashes when domains with some names are created.

AppArmor Support

Plesk Obsidian supports AppArmor on Ubuntu 14.04 and Ubuntu 16.04 only. Before installing Plesk Obsidian on Ubuntu 12.04 or any supported Debian version, disable AppArmor first.

NFS Shares Support

Plesk does not officially support the use of NFS shares for storing vhosts directories. This configuration was not tested and can be used at your own risk.

Supported browsers

The following browsers are supported:

Desktop

  • Mozilla Firefox (latest) for Windows and Mac OS
  • Microsoft Edge® for Windows
  • Apple Safari (latest) for Mac OS
  • Google Chrome (latest) for Windows and Mac OS
  • Opera (latest) for Windows and Mac OS

Smartphones and Tablets

  • Chrome Mobile
  • Apple Safari (latest) on iOS

Supported virtualization

The following virtualization platforms are supported:

  • VMware
  • XEN
  • Virtuozzo 7
  • OpenVZ
  • KVM
  • Hyper-V
  • LXC (Docker)

Notes:

  1. Included in support is ensuring that Plesk functions properly, supports also includes discount licenses for “virtual servers”.
  2. Note that your license key may restrict you to running Plesk on a specific platform only. Your license key may be considered invalid in a different environment, however some functions such as Plesk repair, installation and others will remain working.

Earlier Versions Supported for Upgrade

Plesk Obsidian supports upgrade from the following earlier versions:

  • Plesk Onyx 17.8 for Linux/Windows (x64 only)
  • Plesk Onyx 17.5 for Linux/Windows (x64 only)
  • Plesk Onyx 17.0 for Linux/Windows (x64 only)

Source Hosting Platforms Supported for Migration

Configuration and content from the following hosting platforms can be imported into Plesk Obsidian:

  • Plesk for Linux and Plesk for Windows: 8.6, 9.5, 10.4, 11.0, 11.5, 12.0, 12.5, and Plesk Onyx.
  • cPanel 64 and later
  • Confixx 3.3
  • Helm 3.2
  • Plesk Expand 2.3.2
  • Parallels Pro Control Panel for Linux 10.3.6

Email Clients Supporting Mail Autodiscover

Plesk can automatically set up the following email clients:

  • Microsoft Outlook (except for Microsoft Outlook 2019 and O365)
  • Mozilla Thunderbird
  • Gmail
  • Apple Mail

Learn about email clients supporting mail autodiscover.

 

Plesk Supported Components

Supplied Components

Linux

Plesk Obsidian for Linux distribution packages include the following components:

  • Plesk Premium Antivirus 6.0.2
  • Kaspersky Anti-Virus x86-8.9.2.595, x64-8.9.2.824
  • ImunifyAV
  • AWStats 7.7
  • ProFTPD 1.3.8a
  • qmail 1.03
  • Courier-IMAP 5.2.5
  • Postfix 3.5.20 (for most OSes)
  • Dovecot 2.3.20
  • Horde IMP 5 (requires PHP 7.4)
    • Horde 5.2.23
    • IMP 6.2.27
    • Ingo 3.2.16
    • Kronolith 4.2.29
    • Nag 4.2.19
    • Mnemo 4.2.14
    • Passwd 5.0.7
    • Turba 4.2.29
    • Pear 1.10.9
  • Roundcube 1.6.3 (for OSes other than Red Hat Enterprise Linux 7, CentOS 7,  CloudLinux 7.1, and Ubuntu 18.04)
  • phpMyAdmin 5.2.1
  • nginx 1.24.0
  • OpenSSL 1.1.1n
  • OpenSSL used by nginx 1.1.1n
  • TLS 1.3 (in nginx for customers’ websites)
  • PHP 5.2.17, 5.3.29, 5.4.45, 5.5.38, 5.6.40, 7.0.33, 7.1.33, 7.2.34, 7.3.33, 7.4.33, 8.0.30, 8.1.27, 8.2.15, 8.3.2 *
  • Fail2ban 0.11.2
  • ModSecurity 3.0.11
  • ModSecurity 2.9.7
  • ModSecurity Rule Set 2.2.9-30-g520a94b
  • Resource Controller
  • Node.js 12, 14, 16, 18, 20.x
  • Note: Plesk supports the latest stable and LTS releases of Node.js. Node.js 18 currently not supported on the following OSes:
    • CentOS 7
    • Ubuntu 18.04
    • CloudLinux 7
    • Red Hat Enterprise Linux 7
    • Virtuozzo Linux 7
  • Phusion Passenger 6.0.12
  • Ruby 2.1.10, 2.2.10, 2.3.8, 2.4.6, 2.5.5, 2.6.3, 2.7.7, 3.0.5, 3.1.3, 3.2.1.
  • Bundler 1.13.5
  • Rootkit Hunter 1.4.4

Windows

Plesk Obsidian for Microsoft Windows distribution packages include the following components:

  • Plesk Premium Antivirus 6.0.2
  • Kaspersky Anti-Virus 8.6.1.51
  • ModSecurity 2.9.7
  • Microsoft SQL Server Express 2012 SP3
  • Microsoft SQL Server Express 2014 SP2
  • Microsoft SQL Server Express 2016 SP1
  • Microsoft SQL Server Express 2017
  • Microsoft SQL Server Express 2019
  • Microsoft SQL Server Express 2022
  • MariaDB 10.5.20 (for Plesk database)
  • MariaDB 10.11.3, 10.6.13, 10.5.20, and 10.3.39 (for customer websites)
  • BIND DNS Server 9.16.44
  • MailEnable Standard 10.46
  • PHP 5.6.40, 7.0.33, 7.1.33, 7.2.34, 7.3.33, 7.4.33, 8.0.30, 8.1.27, 8.2.15, 8.3.2 *
  • ASP.NET Core 2.1.28, 3.1.32, 5.0.17, 6.0.22, 7.0.11
  • .NET Core 3.1.3, 2.1.17
  • SpamAssassin 3.0-3.4.5
  • phpMyAdmin 5.0.3
  • AWStats 7.7
  • Webalizer V2.01-10-RB02 (Windows NT 5.2) English
  • Horde 5.2.23 and IMP 6.2.27
  • Microsoft Web Deploy 3.5 + WebMatrix 3.0
  • Microsoft Web Deploy 3.6
  • IIS URL Rewrite Module 7.2.1993
  • Node.js 16.20.2, 18.18.2
  • 7zip 18.05
  • Microsoft Visual C++ 2017 Redistributable

* PHP versions earlier than 8.0 no longer receive security updates because they have been declared “end-of-life” by the product vendor.

Supported Third-Party Components

Linux

Web servers:

  • Apache 2.4

DNS servers:

  • BIND 9.8 or higher

Web statistics:

  • Webalizer 2.x

Web scripting:

  • mod_perl 2.0.8
  • PHP 5.2–8.2

Database servers and tools:

  • MySQL 5.7 and later
  • MySQL community edition 5.7, 8

PostgreSQL 8.4–15

Anti-spam tools:

  • SpamAssassin 3.0–3.4

Windows

This list of third-part components is shortened. Not included in this list are components which come with the Plesk distribution – these are already stipulated as supported as they are included in the distribution.

Web servers:

  • Microsoft Internet Information Services (IIS) 7.5, 8.0, 8.5, 10.0

Mail servers:

  • MailEnable Standard / Professional / Enterprise / Enterprise Premium 6.91–10.46
  • SmarterMail 100, 16.3
  • IceWarp Mail Server 12.0.3.1

Webmail tools:

  • MailEnable Web Client
  • SmarterMail Web Client
  • IceWarp (Merak) Mail Server Web Client

Spam filtering tools:

  • SmarterMail Spamfilter
  • IceWarp (Merak) Mail Server Anti-Spam

Antivirus tools:

  • SmarterMail Anti-Virus
  • IceWarp (Merak) Mail Server Anti-Virus

DNS servers:

  • Microsoft DNS Server

Web statistics:

  • SmarterStats 11.1

Web scripting:

  • ASP
  • ASP.NET 2.0-4.x
  • ASP.NET Core 5.0.15, 6.0.24, 7.0.13 (“Windows Server Hosting (.exe) Runtime” on the download page)
  • Python 2.7.17

Database servers:

  • Microsoft SQL Server 2005–2022
  • MySQL community edition 5.7
  • MySQL ODBC connector 5.3.14
  • PostgreSQL 9.2 and later (remote database servers support only)

Plesk Policy on MariaDB Support

In December 2021, MariaDB announced its new release model: quarterly releases with a one-year maintenance period of each release. MariaDB 10.6 is the last database version that falls under the old release model and has a five-year maintenance period (long-term support).

Taking into account the MariaDB release model, Plesk announces its policy regarding MariaDB support:

  • (MariaDB 10.6 and earlier) Plesk supports each version of MariaDB as a local database server for five years after a MariaDB release. As a local database server, we recommend that you install a long-term support release (LTS release) of MariaDB. At the moment, LTS releases are MariaDB 10.6 and earlier. If MariaDB has other LTS releases in the future, Plesk will support them as a local database server as well.
    Note: The support also applies to subsequent Plesk updates and to Plesk installation on a server with MariaDB already installed from the OS or MariaDB repository.

  • (MariaDB 10.7 and later) Plesk supports each stable version of MariaDB as a remote database server. Plesk introduces the support within one month after a stable MariaDB release.
    Note: It means that the Plesk administrator can register MariaDB in Plesk (Tools & Settings > Database Servers (under “Applications & Databases”)) and then use MariaDB to host users’ databases.

Plesk on Cloud Platforms

Plesk Obsidian is available and compatible with the following cloud platforms
Platform AWS Azure Google Alibaba Lightsail DigitalOcean Linode Vultr Oracle
CentOS 7 (WebHost) 18.0 18.0 18.0
CentOS 7 (BYOL*) 18.0 18.0 18.0 18.0 18.0    
Ubuntu 22.04 (WebHost)*** 18.0 18.0 18.0   18.0
Ubuntu 22.04 (WebPro)***         18.0
Ubuntu** (BYOL*) 18.0 18.0 18.0 18.0 18.0    
Ubuntu 22.04 on ARM (BYOL*) 18.0           18.0
Windows 2022 (WebHost) 18.0 18.0 18.0
Windows 2022 (BYOL*) 18.0 18.0 18.0 18.0    
Plesk WordPress Edition – CentOS 7 18.0 18.0 18.0  
Plesk Business & Collaboration Edition – CentOS 7 18.0 18.0 18.0  
Web Admin SE – CentOS 7       18.0
Web Admin SE – Ubuntu 22.04 18.0     18.0 18.0 18.0
* – “BYOL” equals to “Bring Your Own License”. As soon as Plesk is deployed, you can proceed to use it via 14-day trial license OR buy your own Plesk license ** – Ubuntu 20.04 for Linode ** – After Plesk is deployed on Vultr, you can have it with a free 30-day trial license

7 Comments

  1. Needs correction on the amount of ram. It’s 128MB not 128GB on “128GB of RAM will handle most websites. For example:”.

  2. I did not see any mention of CPU CORES or is that not important?
    how many CORES in required for a smooth sailing of wordpress sites with atleast 30 plugins per site?

  3. I’m positive this once was a great source for requirements, but as the information is now somewhat dated would it not be less confusing to instead link to the below resources?

    Hardware reguirements:
    https://docs.plesk.com/release-notes/current/hardware-requirements/

    Software reguirements:
    https://docs.plesk.com/release-notes/current/software-requirements/

  4. hello, what exactly did you mean about “The minimum amount of RAM required for installing and running Plesk on Linux is 1 GB + 1 GB swap”

    Does it means that at least 2GB of RAM?

    I’d like to deploy new server with this spesification;
    1 vCPU
    1 GB Memory
    1 TB Bandwidth
    Does it enough to install plesk and run my website there?

    • Louis Vanfraechem
      Louis Vanfraechem Moderator

      Hi Christy Han,

      It is still recommended to have SWAP. Actually, the exact specification depends on the website: used technologies, load, etc. Although you can start with minimal requirements, we advise you to be ready to increase your resources. You can always reach out to our dedicated support, as they will be able to look at your situation more closely. Hope this helps.

Add a Comment

Your email address will not be published. Required fields are marked *

GET LATEST NEWS AND TIPS

  • Yes, please, I agree to receiving my personal Plesk Newsletter! WebPros International GmbH and other WebPros group companies may store and process the data I provide for the purpose of delivering the newsletter according to the WebPros Privacy Policy. In order to tailor its offerings to me, Plesk may further use additional information like usage and behavior data (Profiling). I can unsubscribe from the newsletter at any time by sending an email to [email protected] or use the unsubscribe link in any of the newsletters.

Related Posts

Knowledge Base

Plesk uses LiveChat system (3rd party).

By proceeding below, I hereby agree to use LiveChat as an external third party technology. This may involve a transfer of my personal data (e.g. IP Address) to third parties in- or outside of Europe. For more information, please see our Privacy Policy.

Search
Generic filters
Exact matches only
Search in title
Search in content
Search in excerpt