Plesk

 Websites on PHP-FPM are unavailable or loading slowly: “server reached max_children setting” OR “pool seems busy”

Applicable to:

  • Plesk for Linux

Symptoms

Cause

The PHP-FPM pm.max_children has been reached by the website(s).

Resolution

Increase the pm.max_children limit for the affected domains:

  1. Connect to the Plesk server via SSH.

  2. Find affected domains using the command below:

    Note: The number on the left indicates how many times the pm.max_children limit has been reached by the website.

    If a domain is using a dedicated FPM application and has a custom vhosts location, change the path /var/www/vhosts/system/ in the command below:

    # grep -r "server reached max_children setting" /var/log/*php*-fpm/error.log | cut -d' ' -f5 | tr -d ']' | sort | uniq -c | sort -nr

    100 example.com
    50 example.net
    25 example.org
    <...>

  3. Log in to Plesk.

  4. Go to Domains > example.com > PHP Settings > PHP-FPM Settings.

  5. Increase the pm.max_children value for the domain and apply the changes. Increase this value for all domains listed in step 2.

    Note: In this example, we are setting pm.max_children to 20. To fine tune this setting, visit this KB article.


     

     

 

Other options to increase the pm.max_children limit:

 

Increasing pm.max_children for all domains under a service plan via Plesk

 

  1. Log in to Plesk.

  2. Go to Service Plans > plan_name > PHP Settings tab > PHP-FPM Settings section.

  3. Increase the pm.max_children value and click Update & Sync.




    Note: The changes will not be applied to subscriptions if:

    - A subscription is not synced with this service plan (Marked with a blue lock in the Subscriptions menu).
    - If the permission Hosting performance settings management is granted in service plan settings at Service Plans > plan_name > Permissions tab.

 

Increasing pm.max_children for one domain via…
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