Plesk

Unable to issue Let’s Encrypt certificate in Plesk: “Timeout during connect (likely firewall problem)” OR “Error getting validation data”

Symptoms

Cause

Port 80 and/or 443 is filtered by a firewall:

# nmap -p 80 example.com
...
PORT STATE SERVICE
80/tcp filtered http


# nmap -p 443 example.com
PORT STATE SERVICE
443/tcp filtered http

Resolution

Note: If domain example.com resolves to IPv4 and IPv6, HTTP and HTTPS traffic must be allowed to both networks.

As alternative solution, when only IPv6 ports are blocked:

  1. Log in to Plesk

  2. Go to Domains > example.com > Web Hosting Access and disable IPv6 address.

    Note: If the IPv6 address is defined externally it can be removed on the registrar's side.

Additional Information

Unable to issue a Let's Encrypt certificate: The token file is either unreadable or does not have the read permission

What ports need to be opened for all Plesk Services to work with a firewall