Plesk

Unable to create backup in Plesk via the Acronis Backup extension: version `GLIBCXX_3.4.26′ not found

Symptoms

Cause

Acronis agent bug has been fixed in Acronis agent version 15.0 28610.

Resolution

Update Acronis agent using the steps below:

  1. Log into Plesk.

  2. Go to Acronis Backup > Go to backup console. Enter credentials from the Acronis Backup console if required.

  3. In the Acronis Backup console go to Settings > Agents.

  4. In the list of machines select the one with outdated agent versions. They will be marked with an orange exclamation mark.

    Note: The machines must be online.

  5. Click Update agent. After updating make sure there are no unset directives that were previously configured as follows 69808: Acronis Backup extension for Plesk: Backup fails after Plesk update to version 18.0.40:
    2.png

If update is not possible for some reason, apply

manual workaround:

  1. Connect to the Plesk server via SSH.

  2. Open the file /usr/lib/Acronis/BackupAndRecovery/webcpprecapture in a text editor. In this example, we are using the vi editor:

    # vi /usr/lib/Acronis/BackupAndRecovery/webcpprecapture

  3. Add the following lines:

    unset LD_LIBRARY_PATH
    unset LD_PRELOAD

  4. Save the changes and close the file.

Apply the following steps additionally, if Acronis agent version is 28323 (version can be checked in Acronis console).

  1. Connect to the Plesk server via SSH.

  2. Download the patched libwebcp_agent.so file:

    # wget https://plesk.zendesk.com/hc/article_attachments/12376927359895/libwebcp_agent.so

  3. Rename the original file:

    # mv /usr/lib/Acronis/BackupAndRecovery/libwebcp_agent.so /usr/lib/Acronis/BackupAndRecovery/libwebcp_agent.so_backup

  4. Move the downloaded file to the Acronis directory:

    # mv libwebcp_agent.so /usr/lib/Acronis/BackupAndRecovery

  5. Restart the Acronis service:

    # service acronis_mms restart

  6. Verify that Plesk is detected using the command:

    Note: It make take a couple of minutes to take effect.

    # acropsh -m dmldump -s mms -vs InstanceManagement::Instance | grep InstalledApplication

    ('.Parameters.InstalledApplication', 'item_string', 'Plesk'),
    ('.Parameters.InstalledApplication^Searchable', 'nil', None),

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