Plesk

Migration to another Plesk server fails: Unable to restore DNS zone from a backup: Incorrect DNS record values were specified: example.com. IN <Record Type> *.example.com.: (‘ttl’ = ‘0’) – Plesk

Symptoms

Cause

Plesk bug #PPPM-13621 "DNS records with TTL 0 cannot be used."

Resolution

Until the bug is fixed, apply one the following workarounds:

Change the DNS records on the source server before migration:

  1. Connect to the source server via SSH.

  2. Create a dump of the psa database.

  3. Update the ttl value for these records to the default one:

    # plesk db

    update dns_recs set ttl=DEFAULT(ttl) where ttl=0;
    Query OK, 767 rows affected (0.047 sec)
    Rows matched: 767 Changed: 767 Warnings: 0

    select * from dns_recs where ttl=0;
    Empty set (0.003 sec)

  4. Re-sync the migration on the destination server.

  5. Customize TTL on the destination server using the following request to the database for the required DNS record:

    # plesk db "update dns_recs set ttl=0 where host like '%affected_record%';"

Manually recreate DNS records on the target server after migration:

  1. Log in to Plesk on the target server

  2. Create the affected DNS records manually

  3. Customize TTL on the server using the following request to the database for the required DNS record:

    # plesk db "update dns_recs set ttl=0 where host like '%affected_record%';"

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