Symptoms
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MailEnable autoresponder does not send an autoreply.
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In MailEnable Management > Servers > localhost > Servers and Connectors > SMTP > Logs > Activity > SMTP-Activity-date.log following message can be found:
127.0.0.1 AUTH xxxxx 504 Invalid Username or Password 34 18 postmaster@localhost
AUTH xxxxxx 504 User Account has been disabled by the mail administrator 62 18 postmaster@localhost
SMTP-IN XXX.MAI 984 127.0.0.1 RCPT RCPT TO: [email protected] 503 This mail server requires authentication when attempting to send to a non-local e-mail address. Please check your mail client settings or contact your administrator to verify that the domain or address is defined for this server.
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After enabling debug for Plesk backend utilities (How to enable/disable debug logging for Plesk backend utilities on Windows), lines below can be found in
%plesk_dir%adminlogsplesklog_debug<date>.log
:2019/05/23 17:36:14.024 1104 30216 Info: Create mail from='[email protected]', to='[email protected]', subject='Re: Autoreply', body='Test auto-reply'
2019/05/23 17:36:14.025 1104 30216 Info: Send mail from '"" <[email protected]>' to '"" <[email protected]>'
2019/05/23 17:36:14.038 1104 30216 Warning: SMTP Exception
at sendMail([email protected], [email protected])(MessageProcessor::sendMail line 329)
Cause
Account postmaster@localhost is missed or disabled in MailEnable Management or registry.
Resolution
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Connect to the server via RDP.
Note: if direct RDP access to the server is not possible, contact server administrator for further assistance.
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Go to MailEnable Management > Messaging Manager > Post Offices and check whether postmaster user exists under localhost domain. If postmaster user absent:
2.1. Delete localhost domain from MailEnable Management.
2.2. Disable and enable option Use the mail server installed with Plesk and the default mail account created by Plesk in Plesk > Tools & Settings > External SMTP Server.Note: Domain with postmaster@localhost will be recreated by Plesk automatically.
If for some reason use of postmaster@localhost is not suitable, then make sure that 127.0.0.1
is set in Host name or IP address in Plesk > Tools & Settings > External SMTP Server.