Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
-
Attempts to send a message from the Plesk server to a mailbox on
example.com
fails with one of the errors below:# tail -f /usr/local/psa/var/log/maillog | grep 'unknown in virtual mailbox'
550 5.1.1 [email protected]: Recipient address rejected: User unknown in virtual mailbox table; [email protected] [email protected]
example.com postfix-local[23040]: cannot chdir to mailname dir contact: No such file or directory
example.com postfix-local[23040]: Unknown user: [email protected]
ME-E0103: [1076] Local Delivery: Failure - Domain for ([SMTP:[email protected]]) is locally serviced, but recipient is not defined in address map.
-
In webmail, the following error might occur:
Could not send message to SMTP server. Check you have access to send messages via the server and that all To/CC/BCC addresses are valid
Error: SMTP Server rejected email. Returned:550 sorry, no mailbox here by that name. (#5.7.17)
Error SMTP (500): The following recipient could not be reached "[email protected]" (sorry, no mailbox here by that name. (#5.7.17)).
There was an error sending your message: Message could not be delivered - the address was not found, is unknown, or is not receiving messages.
550 5.1.1 [email protected] ... User unknown (in reply to MAIL FROM command))
Cause
The domain example.com
is hosted on the Plesk server but the mail for the domain is hosted on an external mail server/service.
Mail server treats example.com
as a local domain and tries to send emails locally.
Resolution
-
Go to Domains > example.com > Mail Settings
-
Switch the option Activate mail service on this domain to Disabled for incoming mail
Note: With this option, Plesk will not try to deliver emails locally to this domain.
-
Click OK