Plesk

Cannot install Plesk license key, WordPress plugin or a Plesk extension: cURL cannot communicate with license server

Symptoms

Cause

Outgoing connections to the Key Administration server are blocked by a local or intermediate firewall.

Resolution

Allow connection to both ports on all IPs using Plesk interface:

  1. Log into Plesk;
  2. Go to Tools & Settings > Updates & Upgrades. In the extensions section, select Plesk Firewall for installation.
  3. After installation, go to Tools & Settings > Firewall > Enable Firewall Rules Management > Enable;
  4. By default, Plesk Firewall gets activated with the default list of rules, and connection to 5224 and 443 is allowed by default. Make sure there is the following line in Plesk Firewall set to be allowed:

If the connection is still not successful…

Exit mobile version