Symptoms
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Plesk interface is slow. Time to First byte (TTFB) when loading some Plesk pages is very big but server resources are fine.
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License, WordPress plugin or Plesk extension installation fails with one of the following errors:
Error: cURL cannot communicate with license server https://id-00.kaid.plesk.com:5224/ (): Couldn't connect to server(7)
cURL cannot communicate with license server https://id-00.kaid.plesk.com:5224/ (): Couldn't resolve host name(6)cURL cannot communicate with license server https://id-00.kaid.plesk.com:443/ (195.214.233.82): SSL connect error(35) cURL cannot communicate with license server https://id-00.kaid.plesk.com:443/ (): Couldn't resolve host name(6) (Error code: 2)
Error: No properly formed ip addresses
Error: The license key is invalid. In order to use Plesk, you need to obtain and install a new valid license key. Your license key has expired. To continue using your Plesk, you must purchase a non-expiring commercial license key. Error: cURL cannot communicate with license server https://id-00.kaid.swsoft.com:5224/ (): Failed to connect to id-00.kaid.swsoft.com port 5224: Bad access(7) cURL cannot communicate with license server https://id-00.kaid.swsoft.com:5224/ (): Could not resolve host: id-00.kaid.swsoft.com(6)
ERR [panel] KeyUpdate Result additional information: cURL verbose output: * Trying 195.214.233.80... * connect to 195.214.233.80 port 5224 failed: Bad access * Failed to connect to ka.plesk.com port 5224: Bad access * Closing connection 0
cURL cannot communicate with license server https://ka.plesk.com/xmlrpc(): Failed to connect to ka.plesk.com port 443: Timed out(7)
cURL cannot communicate with license server https://ka.plesk.com/xmlrpc(): Could not resolve host: ka.plesk.com(6) -
One of the following symptoms is true:
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Cannot connect to
ka.plesk.com
usingtelnet
utility:# telnet ka.plesk.com 443
Trying 195.214.233.80...
telnet: Unable to connect to remote host: Connection refusedOR
# telnet ka.plesk.com 443
Trying 195.214.233.80...
telnet: connect to address 195.214.233.80: Connection timed out
Trying 195.214.233.81...
telnet: connect to address 195.214.233.81: Connection timed out
Trying 195.214.233.82...
telnet: connect to address 195.214.233.82: Connection timed out -
cURL HTTPS request fails with:
# curl --insecure https://ka.plesk.com:443
curl: (35) TCP connection reset by peer -
# curl https://ka.plesk.com:443 -v
...
* Connected to ka.plesk.com (195.214.233.81) port 443 (#0)
...
* Cipher selection: ALL:!EXPORT:!EXPORT40:!EXPORT56:!aNULL:!LOW:!RC4:@STRENGTH
...
* TLSv1.2 (OUT), TLS handshake, Client hello (1):
* Unknown SSL protocol error in connection to ka.plesk.com:443
...
curl: (35) Unknown SSL protocol error in connection to ka.plesk.com:443 -
Or:
PS > New-Object System.Net.Sockets.TcpClient("ka.plesk.com", 443)
Client : System.Net.Sockets.Socket
Available : 0
Connected : False
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Cause
Outgoing connections to the Key Administration server are blocked by a local or intermediate firewall.
Resolution
Allow connection to both ports on all IPs using Plesk interface:
- Log into Plesk;
- Go to Tools & Settings > Updates & Upgrades. In the extensions section, select Plesk Firewall for installation.
- After installation, go to Tools & Settings > Firewall > Enable Firewall Rules Management > Enable;
- By default, Plesk Firewall gets activated with the default list of rules, and connection to 5224 and 443 is allowed by default. Make sure there is the following line in Plesk Firewall set to be allowed:
If the connection is still not successful…