Plesk

A lot of emails in Mail Queue that are not being processed in Plesk

Symptoms

Cause

Server's IP addresses are blacklisted on recipient's side or in the reputation centers which are used by a recipient mail servers.

Resolution

  1. Make sure that the server is not a source of SPAM. Check Plesk documentation to find what Plesk features can be used to protect the server from outbound spam - Protection from Outbound Spam

  2. Contact a recipient with a request to remove affected IPs from recipient's mail server blacklist.

 

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